summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-05-22 23:29:12 +0200
committerBenjamin Chrétien2016-05-22 23:29:12 +0200
commit5e01b3a9b0336650e3fc4dd32b16f4af0f0a0a83 (patch)
tree5ee247e1c5cfb9443dad7896886299dd1412d8c6
parentf97ff75250678e1d07b2b2d5a3e92295ae27785a (diff)
downloadaur-5e01b3a9b0336650e3fc4dd32b16f4af0f0a0a83.tar.gz
Update to version 1.11.19 (pkgrel 1)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d69dbd58137..803555330a0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Jan 23 08:00:53 UTC 2016
+# Sun May 22 21:29:10 UTC 2016
pkgbase = ros-jade-rosgraph
pkgdesc = ROS - rosgraph contains the rosgraph command-line tool, which prints information about the ROS Computation Graph.
- pkgver = 1.11.16
+ pkgver = 1.11.19
pkgrel = 1
url = http://ros.org/wiki/rosgraph
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-jade-catkin
depends = python2-rospkg
depends = python2-netifaces
- source = rosgraph::git+https://github.com/ros-gbp/ros_comm-release.git#tag=release/jade/rosgraph/1.11.16-0
- md5sums = SKIP
+ source = ros-jade-rosgraph-1.11.19-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/jade/rosgraph/1.11.19-0.tar.gz
+ sha256sums = 438d1df3192e58987c63cd19d5fb0526988eb8a58d0eeb33a5a29db02613d938
pkgname = ros-jade-rosgraph
diff --git a/PKGBUILD b/PKGBUILD
index 4933746ad146..2a31463c5819 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgdesc="ROS - rosgraph contains the rosgraph command-line tool, which prints in
url='http://ros.org/wiki/rosgraph'
pkgname='ros-jade-rosgraph'
-pkgver='1.11.16'
+pkgver='1.11.19'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-jade-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=()
@@ -19,10 +19,16 @@ depends=(${ros_depends[@]}
python2-rospkg
python2-netifaces)
-_tag=release/jade/rosgraph/${pkgver}-${_pkgver_patch}
-_dir=rosgraph
-source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/jade/rosgraph/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-jade-rosgraph-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/jade/rosgraph/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('438d1df3192e58987c63cd19d5fb0526988eb8a58d0eeb33a5a29db02613d938')
build() {
# Use ROS environment variables