summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-20 19:58:24 +0900
committerBenjamin Chrétien2015-06-20 19:58:24 +0900
commitb5c5dd68c9ce8bc2134b22b4fc84cb5b2dd21ea4 (patch)
treed2fd2ecd8d73ff2f61d4577f512d07d443838b72
downloadaur-b5c5dd68c9ce8bc2134b22b4fc84cb5b2dd21ea4.tar.gz
jade: add desktop and its dependencies
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD61
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5102c794d754
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ros-jade-rqt-plot
+ pkgdesc = ROS - rqt_plot provides a GUI plugin visualizing numeric values in a 2D plot using different plotting backends.
+ pkgver = 0.3.11
+ pkgrel = 1
+ url = http://ros.org/wiki/rqt_plot
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-jade-catkin
+ depends = ros-jade-rqt-gui-py
+ depends = ros-jade-rostopic
+ depends = ros-jade-rqt-gui
+ depends = ros-jade-qt-gui-py-common
+ depends = ros-jade-rosgraph
+ depends = ros-jade-rqt-py-common
+ depends = python2-rospkg
+ depends = pyqwt
+ depends = python2-matplotlib
+ source = rqt_plot::git+https://github.com/ros-gbp/rqt_common_plugins-release.git#tag=release/jade/rqt_plot/0.3.11-0
+ md5sums = SKIP
+
+pkgname = ros-jade-rqt-plot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aac2f795eee3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_plot provides a GUI plugin visualizing numeric values in a 2D plot using different plotting backends."
+url='http://ros.org/wiki/rqt_plot'
+
+pkgname='ros-jade-rqt-plot'
+pkgver='0.3.11'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-jade-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-jade-rqt-gui-py
+ ros-jade-rostopic
+ ros-jade-rqt-gui
+ ros-jade-qt-gui-py-common
+ ros-jade-rosgraph
+ ros-jade-rqt-py-common)
+depends=(${ros_depends[@]}
+ python2-rospkg
+ pyqwt
+ python2-matplotlib)
+
+_tag=release/jade/rqt_plot/${pkgver}-${_pkgver_patch}
+_dir=rqt_plot
+source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}