summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-20 21:48:33 +0900
committerBenjamin Chrétien2015-06-20 21:48:33 +0900
commit44af857cea3f210f0bd1bab5f4d83405fb42e5d0 (patch)
tree9d91f21521817819ddd631e8519f74e33869a2e4
downloadaur-44af857cea3f210f0bd1bab5f4d83405fb42e5d0.tar.gz
jade: add desktop_full and its dependencies
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD62
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22655e6bb22d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ros-jade-stage
+ pkgdesc = ROS - Mobile robot simulator http://rtv.github.com/Stage.
+ pkgver = 4.1.1
+ pkgrel = 3
+ url = http://rtv.github.com/Stage
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = fltk
+ makedepends = libjpeg-turbo
+ makedepends = gtk2
+ makedepends = libtool
+ makedepends = mesa
+ makedepends = pkg-config
+ depends = ros-jade-catkin
+ depends = libjpeg-turbo
+ depends = mesa
+ depends = gtk2
+ source = stage::git+https://github.com/ros-gbp/stage-release.git#tag=release/jade/stage/4.1.1-2
+ md5sums = SKIP
+
+pkgname = ros-jade-stage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..872beb8f0436
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Mobile robot simulator http://rtv.github.com/Stage."
+url='http://rtv.github.com/Stage'
+
+pkgname='ros-jade-stage'
+pkgver='4.1.1'
+_pkgver_patch=2
+arch=('any')
+pkgrel=3
+license=('GPL')
+
+ros_makedepends=()
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ fltk
+ libjpeg-turbo
+ gtk2
+ libtool
+ mesa
+ pkg-config)
+
+ros_depends=(ros-jade-catkin)
+depends=(${ros_depends[@]}
+ libjpeg-turbo
+ mesa
+ gtk2)
+
+_tag=release/jade/stage/${pkgver}-${_pkgver_patch}
+_dir=stage
+source=("${_dir}"::"git+https://github.com/ros-gbp/stage-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}