summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-10-30 17:24:24 -0700
committerSean Greenslade2017-10-30 17:24:24 -0700
commit927128eb210a28228ed1772edda5c7da241d6cca (patch)
tree97f72636e0a52d2e21de44a378b18de6f73af4f3
downloadaur-927128eb210a28228ed1772edda5c7da241d6cca.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f305c7e0809f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Oct 31 00:24:24 UTC 2017
+pkgbase = ros-kinetic-ecl-license
+ pkgdesc = ROS - Maintains the ecl licenses and also provides an install target for deploying licenses with the ecl libraries.
+ pkgver = 0.61.6
+ pkgrel = 1
+ url = http://wiki.ros.org/ecl_license
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ source = ros-kinetic-ecl-license-0.61.6-0.tar.gz::https://github.com/yujinrobot-release/ecl_tools-release/archive/release/kinetic/ecl_license/0.61.6-0.tar.gz
+ sha256sums = 5e5a1aa98eb6ba4c14991fda69811ce6e951848be8ff47745a5a8031e3cf0fd1
+
+pkgname = ros-kinetic-ecl-license
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f401392c4e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Maintains the ecl licenses and also provides an install target for deploying licenses with the ecl libraries."
+url='http://wiki.ros.org/ecl_license'
+
+pkgname='ros-kinetic-ecl-license'
+pkgver='0.61.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/ecl_license/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/yujinrobot-release/ecl_tools-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ecl_tools-release-release-kinetic-ecl_license-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/yujinrobot-release/ecl_tools-release/archive/release/kinetic/ecl_license/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('5e5a1aa98eb6ba4c14991fda69811ce6e951848be8ff47745a5a8031e3cf0fd1')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}