summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-09-09 19:50:18 -0700
committerSean Greenslade2017-09-09 19:50:18 -0700
commit49b6277335b252b646d554e2aadcd4d3b469e6b6 (patch)
tree194406c4dde32f90e30de90b326725e6da4f98de
downloadaur-49b6277335b252b646d554e2aadcd4d3b469e6b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD61
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b0900ea38cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 10 02:50:18 UTC 2017
+pkgbase = ros-kinetic-gazebo-dev
+ pkgdesc = ROS - Provides a cmake config for the default version of Gazebo for the ROS distribution.
+ pkgver = 2.5.13
+ pkgrel = 1
+ url = http://gazebosim.org/tutorials?cat=connect_ros
+ arch = any
+ license = Apache 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = gazebo
+ depends = libgazebo7-dev
+ source = ros-kinetic-gazebo-dev-2.5.13-0.tar.gz::https://github.com/ros-gbp/gazebo_ros_pkgs-release/archive/release/kinetic/gazebo_dev/2.5.13-0.tar.gz
+ sha256sums = 1fefd49d868f46e7669074411d58ceeb296dd542b1e308a6631f61b698ac2a24
+
+pkgname = ros-kinetic-gazebo-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7a8498558e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Provides a cmake config for the default version of Gazebo for the ROS distribution."
+url='http://gazebosim.org/tutorials?cat=connect_ros'
+
+pkgname='ros-kinetic-gazebo-dev'
+pkgver='2.5.13'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache 2.0')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ gazebo
+ libgazebo7-dev)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/gazebo_dev/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/gazebo_ros_pkgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="gazebo_ros_pkgs-release-release-kinetic-gazebo_dev-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/gazebo_ros_pkgs-release/archive/release/kinetic/gazebo_dev/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('1fefd49d868f46e7669074411d58ceeb296dd542b1e308a6631f61b698ac2a24')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}