summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-03-04 17:08:50 +0100
committerTim Rakowski2017-03-04 17:08:50 +0100
commit7bb816c58acbc0e4a3b0144639a8e95b741aadf8 (patch)
treea46bd591c3b8562900d70e2e25b0b9e4215ec859
downloadaur-7bb816c58acbc0e4a3b0144639a8e95b741aadf8.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69d63704ab85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Mar 4 16:08:50 UTC 2017
+pkgbase = ros-kinetic-ivcon
+ pkgdesc = ROS - Mesh Conversion Utility Used to generate .iv files from .stl files.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://sourceforge.net/projects/ivcon/
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ source = ros-kinetic-ivcon-0.1.6-0.tar.gz::https://github.com/ros-gbp/ivcon-release/archive/release/kinetic/ivcon/0.1.6-0.tar.gz
+ sha256sums = e5fcd7bf432c4c2d73b6bf851b4e88a055a05cd88cb15a90b96a6d3b38847489
+
+pkgname = ros-kinetic-ivcon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e69a7762168e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Mesh Conversion Utility Used to generate .iv files from .stl files."
+url='https://sourceforge.net/projects/ivcon/'
+
+pkgname='ros-kinetic-ivcon'
+pkgver='0.1.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('GPL')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/ivcon/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ivcon-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ivcon-release-release-kinetic-ivcon-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ivcon-release/archive/release/kinetic/ivcon/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e5fcd7bf432c4c2d73b6bf851b4e88a055a05cd88cb15a90b96a6d3b38847489')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}