summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiras Zaidan2017-08-10 21:20:37 +0200
committerFiras Zaidan2017-08-10 21:20:37 +0200
commit28a7bdab7435b36acbc49cf931c6b26f67ac1145 (patch)
treed182b16cc65ad92ad9a51471cfb78635ce8ba343
downloadaur-28a7bdab7435b36acbc49cf931c6b26f67ac1145.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD74
2 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ecfa1b3a42f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = ros-kinetic-navigation
+ pkgdesc = ROS - A 2D navigation stack that takes in information from odometry, sensor streams, and a goal pose and outputs safe velocity commands that are sent to a mobile base.
+ pkgver = 1.14.1
+ pkgrel = 0
+ url = http://wiki.ros.org/navigation
+ arch = any
+ license = BSD,LGPL,LGPL (amcl)
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-nav-core
+ depends = ros-kinetic-carrot-planner
+ depends = ros-kinetic-fake-localization
+ depends = ros-kinetic-clear-costmap-recovery
+ depends = ros-kinetic-base-local-planner
+ depends = ros-kinetic-amcl
+ depends = ros-kinetic-navfn
+ depends = ros-kinetic-global-planner
+ depends = ros-kinetic-map-server
+ depends = ros-kinetic-voxel-grid
+ depends = ros-kinetic-dwa-local-planner
+ depends = ros-kinetic-robot-pose-ekf
+ depends = ros-kinetic-move-base-msgs
+ depends = ros-kinetic-move-slow-and-clear
+ depends = ros-kinetic-costmap-2d
+ depends = ros-kinetic-rotate-recovery
+ depends = ros-kinetic-move-base
+ source = ros-kinetic-navigation-1.14.1-0.tar.gz::https://github.com/ros-gbp/navigation-release/archive/release/kinetic/navigation/1.14.1-0.tar.gz
+ sha256sums = a638a6f3791c62c5e123cc6a3eeabeef903ddc74b50365d606d6c56317bcd6cf
+
+pkgname = ros-kinetic-navigation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..673a6ea2f526
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Firas Zaidan <firas@zaidan.de>
+pkgdesc="ROS - A 2D navigation stack that takes in information from odometry, sensor streams, and a goal pose and outputs safe velocity commands that are sent to a mobile base."
+url='http://wiki.ros.org/navigation'
+
+pkgname='ros-kinetic-navigation'
+pkgver='1.14.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=0
+license=('BSD,LGPL,LGPL (amcl)')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-nav-core
+ ros-kinetic-carrot-planner
+ ros-kinetic-fake-localization
+ ros-kinetic-clear-costmap-recovery
+ ros-kinetic-base-local-planner
+ ros-kinetic-amcl
+ ros-kinetic-navfn
+ ros-kinetic-global-planner
+ ros-kinetic-map-server
+ ros-kinetic-voxel-grid
+ ros-kinetic-dwa-local-planner
+ ros-kinetic-robot-pose-ekf
+ ros-kinetic-move-base-msgs
+ ros-kinetic-move-slow-and-clear
+ ros-kinetic-costmap-2d
+ ros-kinetic-rotate-recovery
+ ros-kinetic-move-base)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/navigation/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/navigation-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="navigation-release-release-kinetic-navigation-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/navigation-release/archive/release/kinetic/navigation/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('a638a6f3791c62c5e123cc6a3eeabeef903ddc74b50365d606d6c56317bcd6cf')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}