summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-02-12 18:29:53 -0800
committerSean Greenslade2017-02-12 18:29:53 -0800
commit89b94190224b6ded1939af5075ccb860cb59080d (patch)
tree2023b18a7f5c5f1a040eaf23dda6b4cbe16af263
downloadaur-89b94190224b6ded1939af5075ccb860cb59080d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0197f80b77a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 02:29:53 UTC 2017
+pkgbase = ros-kinetic-qt-gui-py-common
+ pkgdesc = ROS - qt_gui_py_common provides common functionality for GUI plugins written in Python.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = http://ros.org/wiki/qt_gui_py_common
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-python-qt-binding
+ depends = python2-rospkg
+ source = ros-kinetic-qt-gui-py-common-0.3.4-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/kinetic/qt_gui_py_common/0.3.4-0.tar.gz
+ sha256sums = 7ca874be175ac57321398baa2ea13ed4ef787df7a75c11f32e37c775d50f9746
+
+pkgname = ros-kinetic-qt-gui-py-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b85183507dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - qt_gui_py_common provides common functionality for GUI plugins written in Python."
+url='http://ros.org/wiki/qt_gui_py_common'
+
+pkgname='ros-kinetic-qt-gui-py-common'
+pkgver='0.3.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-python-qt-binding)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/qt_gui_py_common/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="qt_gui_core-release-release-kinetic-qt_gui_py_common-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/kinetic/qt_gui_py_common/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('7ca874be175ac57321398baa2ea13ed4ef787df7a75c11f32e37c775d50f9746')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}