summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:33:45 -0800
committerSean Greenslade2016-12-20 21:33:45 -0800
commit6fec75334a4d3e814137ad2f98283261f2e47bff (patch)
treeaaa20852493bc8e49bd8f06474a074f4fd882061
downloadaur-ros-kinetic-rosboost-cfg.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03b3965bf03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:33:45 UTC 2016
+pkgbase = ros-kinetic-rosboost-cfg
+ pkgdesc = ROS - Contains scripts used by the rosboost-cfg tool for determining cflags/lflags/etc.
+ pkgver = 1.13.4
+ pkgrel = 1
+ url = http://ros.org/wiki/rosboost_cfg
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ source = ros-kinetic-rosboost-cfg-1.13.4-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/kinetic/rosboost_cfg/1.13.4-0.tar.gz
+ sha256sums = 6de32b4b3a95933937c220b1e3a3c1486c930398123fbfd07d52a3e3e306754d
+
+pkgname = ros-kinetic-rosboost-cfg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9572e555942b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Contains scripts used by the rosboost-cfg tool for determining cflags/lflags/etc."
+url='http://ros.org/wiki/rosboost_cfg'
+
+pkgname='ros-kinetic-rosboost-cfg'
+pkgver='1.13.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rosboost_cfg/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-kinetic-rosboost_cfg-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/kinetic/rosboost_cfg/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('6de32b4b3a95933937c220b1e3a3c1486c930398123fbfd07d52a3e3e306754d')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}