summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:33:50 -0800
committerSean Greenslade2016-12-20 21:33:50 -0800
commit4037caf4f4c827099682f9b1ed4f33e606bdf586 (patch)
tree3331f53cd6d756bb2b3b1764346a465c08395b2b
downloadaur-4037caf4f4c827099682f9b1ed4f33e606bdf586.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD60
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0925fb1eac70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:33:50 UTC 2016
+pkgbase = ros-kinetic-rosclean
+ pkgdesc = ROS - rosclean: cleanup filesystem resources (e.g.
+ pkgver = 1.13.4
+ pkgrel = 1
+ url = http://ros.org/wiki/rosclean
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = python2-rospkg
+ source = ros-kinetic-rosclean-1.13.4-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/kinetic/rosclean/1.13.4-0.tar.gz
+ sha256sums = 93c7a19146d5a52c087f2aad4490e3a6bb102668355c36dfe91a53d7c9ee2500
+
+pkgname = ros-kinetic-rosclean
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67d163b7a116
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rosclean: cleanup filesystem resources (e.g."
+url='http://ros.org/wiki/rosclean'
+
+pkgname='ros-kinetic-rosclean'
+pkgver='1.13.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rosclean/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-kinetic-rosclean-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/kinetic/rosclean/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('93c7a19146d5a52c087f2aad4490e3a6bb102668355c36dfe91a53d7c9ee2500')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}