summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:32:32 -0800
committerSean Greenslade2016-12-20 21:32:32 -0800
commit673d5f230a5804db3f0a3924b14b1bdec94ae4da (patch)
tree61fa6e0492f472aa24918c75508445f2b01598f6
downloadaur-673d5f230a5804db3f0a3924b14b1bdec94ae4da.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93167e9087da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:32:32 UTC 2016
+pkgbase = ros-kinetic-roscpp-serialization
+ pkgdesc = ROS - roscpp_serialization contains the code for serialization as described in MessagesSerializationAndAdaptingTypes.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = http://ros.org/wiki/roscpp_serialization
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ makedepends = ros-kinetic-rostime
+ makedepends = ros-kinetic-cpp-common
+ makedepends = ros-kinetic-roscpp-traits
+ depends = ros-kinetic-rostime
+ depends = ros-kinetic-cpp-common
+ depends = ros-kinetic-roscpp-traits
+ source = ros-kinetic-roscpp-serialization-0.6.1-0.tar.gz::https://github.com/ros-gbp/roscpp_core-release/archive/release/kinetic/roscpp_serialization/0.6.1-0.tar.gz
+ sha256sums = ed648dd62d24392f31a6225c1533f014e0c51ea3e26e4fd98f998656c6621913
+
+pkgname = ros-kinetic-roscpp-serialization
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50a266ee6f7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - roscpp_serialization contains the code for serialization as described in MessagesSerializationAndAdaptingTypes."
+url='http://ros.org/wiki/roscpp_serialization'
+
+pkgname='ros-kinetic-roscpp-serialization'
+pkgver='0.6.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin
+ ros-kinetic-rostime
+ ros-kinetic-cpp-common
+ ros-kinetic-roscpp-traits)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rostime
+ ros-kinetic-cpp-common
+ ros-kinetic-roscpp-traits)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/roscpp_serialization/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="roscpp_core-release-release-kinetic-roscpp_serialization-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roscpp_core-release/archive/release/kinetic/roscpp_serialization/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ed648dd62d24392f31a6225c1533f014e0c51ea3e26e4fd98f998656c6621913')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}