summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:35:48 -0800
committerSean Greenslade2016-12-20 21:35:48 -0800
commite8205ef53e6437069bb39a42010fdd847bec1b19 (patch)
tree0357699af126aedcd6862e48d8b0c9a754fa0e17
downloadaur-e8205ef53e6437069bb39a42010fdd847bec1b19.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26c63eff2f41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:35:48 UTC 2016
+pkgbase = ros-kinetic-rostopic
+ pkgdesc = ROS - rostopic contains the rostopic command-line tool for displaying debug information about ROS Topics, including publishers, subscribers, publishing rate, and ROS Messages.
+ pkgver = 1.12.6
+ pkgrel = 1
+ url = http://ros.org/wiki/rostopic
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-rostest
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-rospy
+ depends = ros-kinetic-genpy
+ depends = ros-kinetic-rosbag
+ source = ros-kinetic-rostopic-1.12.6-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/rostopic/1.12.6-0.tar.gz
+ sha256sums = 4fc5ba6bef7fe3713fda9f76e8048e4c82ca8ed81d3faf8a4281837ecd4e4948
+
+pkgname = ros-kinetic-rostopic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef80e3035d0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rostopic contains the rostopic command-line tool for displaying debug information about ROS Topics, including publishers, subscribers, publishing rate, and ROS Messages."
+url='http://ros.org/wiki/rostopic'
+
+pkgname='ros-kinetic-rostopic'
+pkgver='1.12.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-rostest
+ ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rospy
+ ros-kinetic-genpy
+ ros-kinetic-rosbag)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rostopic/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-kinetic-rostopic-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/rostopic/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('4fc5ba6bef7fe3713fda9f76e8048e4c82ca8ed81d3faf8a4281837ecd4e4948')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}