summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-02-12 18:30:39 -0800
committerSean Greenslade2017-02-12 18:30:39 -0800
commit65538f8ed6ac81c7fe4358baf8bc2758181f4a99 (patch)
tree97b018b99be075d06467633630bac75578d28997
downloadaur-65538f8ed6ac81c7fe4358baf8bc2758181f4a99.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD65
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1f9789aff02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 02:30:39 UTC 2017
+pkgbase = ros-kinetic-rqt-py-console
+ pkgdesc = ROS - rqt_py_console is a Python GUI plugin providing an interactive Python console.
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = http://ros.org/wiki/rqt_py_console
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-qt-gui
+ depends = ros-kinetic-rqt-gui-py
+ depends = ros-kinetic-rqt-gui
+ depends = ros-kinetic-qt-gui-py-common
+ depends = ros-kinetic-rospy
+ depends = ros-kinetic-python-qt-binding
+ depends = python2-rospkg
+ source = ros-kinetic-rqt-py-console-0.4.5-0.tar.gz::https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/kinetic/rqt_py_console/0.4.5-0.tar.gz
+ sha256sums = c5c3a46a9c41dc1832f1d585bbe4433d313f76faa074c20708d02acf994c1588
+
+pkgname = ros-kinetic-rqt-py-console
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f2f4159479a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_py_console is a Python GUI plugin providing an interactive Python console."
+url='http://ros.org/wiki/rqt_py_console'
+
+pkgname='ros-kinetic-rqt-py-console'
+pkgver='0.4.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-qt-gui
+ ros-kinetic-rqt-gui-py
+ ros-kinetic-rqt-gui
+ ros-kinetic-qt-gui-py-common
+ ros-kinetic-rospy
+ ros-kinetic-python-qt-binding)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rqt_py_console/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_common_plugins-release-release-kinetic-rqt_py_console-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/kinetic/rqt_py_console/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c5c3a46a9c41dc1832f1d585bbe4433d313f76faa074c20708d02acf994c1588')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}