summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormajor major2017-03-02 03:52:09 +0100
committermajor major2017-03-02 03:52:09 +0100
commit5f8ce0078c21ed81be48c523ba4ed63b15276013 (patch)
treed8184a3990b2c3d367a21e79957caf16b1f5985e
downloadaur-5f8ce0078c21ed81be48c523ba4ed63b15276013.tar.gz
Updated package to Ros Kinetic
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..593cccea53bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros-kinetic-rviz-python-tutorial
+ pkgdesc = ROS - Tutorials showing how to call into rviz internals from python scripts.
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = http://ros.org/wiki/rviz_python_tutorial
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-rviz
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-rviz
+ source = rviz_python_tutorial::git+https://github.com/ros-gbp/visualization_tutorials-release.git#tag=release/kinetic/rviz_python_tutorial/0.10.1-0
+ md5sums = SKIP
+
+pkgname = ros-kinetic-rviz-python-tutorial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee713a2750e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Tutorials showing how to call into rviz internals from python scripts."
+url='http://ros.org/wiki/rviz_python_tutorial'
+
+pkgname='ros-kinetic-rviz-python-tutorial'
+pkgver='0.10.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-rviz
+ ros-kinetic-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rviz)
+depends=(${ros_depends[@]})
+
+_tag=release/kinetic/rviz_python_tutorial/${pkgver}-${_pkgver_patch}
+_dir=rviz_python_tutorial
+source=("${_dir}"::"git+https://github.com/ros-gbp/visualization_tutorials-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}