summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:38:28 -0800
committerSean Greenslade2016-12-20 21:38:28 -0800
commit2defe67ca534213b28d84471761d0a9bebd689eb (patch)
tree20bfdbca9bc429a489ebefae50a441723a50bb91
downloadaur-2defe67ca534213b28d84471761d0a9bebd689eb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ec4b5b51601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:38:28 UTC 2016
+pkgbase = ros-kinetic-smach
+ pkgdesc = ROS - SMACH is a task-level architecture for rapidly creating complex robot behavior.
+ pkgver = 2.0.0
+ pkgrel = 3
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ source = ros-kinetic-smach-2.0.0-2.tar.gz::https://github.com/ros-gbp/executive_smach-release/archive/release/kinetic/smach/2.0.0-2.tar.gz
+ sha256sums = 7f2083ab8eeefdf9f31b0c18630a191e743631c5be6f88ad42b6eb0439a14a43
+
+pkgname = ros-kinetic-smach
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..248bc0743ca9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - SMACH is a task-level architecture for rapidly creating complex robot behavior."
+url='http://www.ros.org/'
+
+pkgname='ros-kinetic-smach'
+pkgver='2.0.0'
+_pkgver_patch=2
+arch=('any')
+pkgrel=3
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/smach/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/executive_smach-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="executive_smach-release-release-kinetic-smach-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/executive_smach-release/archive/release/kinetic/smach/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('7f2083ab8eeefdf9f31b0c18630a191e743631c5be6f88ad42b6eb0439a14a43')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}