summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:38:32 -0800
committerSean Greenslade2016-12-20 21:38:32 -0800
commitaad330c3e79e56dcfb04ecb3dea6d9ae0113d728 (patch)
treeb89ea1d794b0a0d4490b3706c94d37d69c5e0981
downloadaur-aad330c3e79e56dcfb04ecb3dea6d9ae0113d728.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eb7126bda48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 05:38:32 UTC 2016
+pkgbase = ros-kinetic-smach-msgs
+ pkgdesc = ROS - this package contains a set of messages that are used by the introspection interfaces for smach.
+ pkgver = 2.0.0
+ pkgrel = 3
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-message-generation
+ makedepends = ros-kinetic-catkin
+ makedepends = ros-kinetic-std-msgs
+ depends = ros-kinetic-message-runtime
+ depends = ros-kinetic-std-msgs
+ source = ros-kinetic-smach-msgs-2.0.0-2.tar.gz::https://github.com/ros-gbp/executive_smach-release/archive/release/kinetic/smach_msgs/2.0.0-2.tar.gz
+ sha256sums = 3a5afa934becbcf2be023ea2b7008c61c3baad5b0e8c2242cc8f96567bfd9c1d
+
+pkgname = ros-kinetic-smach-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77843e5001b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - this package contains a set of messages that are used by the introspection interfaces for smach."
+url='http://www.ros.org/'
+
+pkgname='ros-kinetic-smach-msgs'
+pkgver='2.0.0'
+_pkgver_patch=2
+arch=('any')
+pkgrel=3
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-message-generation
+ ros-kinetic-catkin
+ ros-kinetic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-message-runtime
+ ros-kinetic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/smach_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/executive_smach-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="executive_smach-release-release-kinetic-smach_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/executive_smach-release/archive/release/kinetic/smach_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('3a5afa934becbcf2be023ea2b7008c61c3baad5b0e8c2242cc8f96567bfd9c1d')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}