summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2017-10-30 17:22:42 -0700
committerSean Greenslade2017-10-30 17:22:42 -0700
commita97005b9fd4aec859c4a5fbcec3d0a7886583a18 (patch)
tree475ba7d883ab4a475e2b2844fd78989d668bae34
downloadaur-a97005b9fd4aec859c4a5fbcec3d0a7886583a18.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD65
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26719a277fc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Oct 31 00:22:41 UTC 2017
+pkgbase = ros-kinetic-tf2-bullet
+ pkgdesc = ROS - tf2_bullet.
+ pkgver = 0.5.16
+ pkgrel = 1
+ url = http://www.ros.org/wiki/tf2_bullet
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-geometry-msgs
+ makedepends = ros-kinetic-tf2
+ makedepends = ros-kinetic-catkin
+ makedepends = bullet
+ makedepends = pkg-config
+ depends = ros-kinetic-geometry-msgs
+ depends = ros-kinetic-tf2
+ depends = bullet
+ source = ros-kinetic-tf2-bullet-0.5.16-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/kinetic/tf2_bullet/0.5.16-0.tar.gz
+ sha256sums = 02d4070099d899df9753ffe6feabd910233d5960fcaa0011a7b5a136fc4fccee
+
+pkgname = ros-kinetic-tf2-bullet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..374ff68c9d3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - tf2_bullet."
+url='http://www.ros.org/wiki/tf2_bullet'
+
+pkgname='ros-kinetic-tf2-bullet'
+pkgver='0.5.16'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-geometry-msgs
+ ros-kinetic-tf2
+ ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ bullet
+ pkg-config)
+
+ros_depends=(ros-kinetic-geometry-msgs
+ ros-kinetic-tf2)
+depends=(${ros_depends[@]}
+ bullet)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/tf2_bullet/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="geometry2-release-release-kinetic-tf2_bullet-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/kinetic/tf2_bullet/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('02d4070099d899df9753ffe6feabd910233d5960fcaa0011a7b5a136fc4fccee')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}