summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:40:58 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit836c7fcf0181c9acfe78bb5bfb2727650f03fbc1 (patch)
tree99b3a6775f6f9a74369f5092580afefea1de8321
downloadaur-836c7fcf0181c9acfe78bb5bfb2727650f03fbc1.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD72
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72c9b99a83dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:33 UTC 2017
+pkgbase = ros-lunar-actionlib
+ pkgdesc = ROS - The actionlib stack provides a standardized interface for interfacing with preemptable tasks.
+ pkgver = 1.11.9
+ pkgrel = 1
+ url = http://www.ros.org/wiki/actionlib
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-roscpp
+ makedepends = ros-lunar-rospy
+ makedepends = ros-lunar-std-msgs
+ makedepends = ros-lunar-rostest
+ makedepends = ros-lunar-message-generation
+ makedepends = ros-lunar-actionlib-msgs
+ makedepends = boost
+ depends = ros-lunar-roscpp
+ depends = ros-lunar-rospy
+ depends = ros-lunar-std-msgs
+ depends = ros-lunar-rostest
+ depends = ros-lunar-message-runtime
+ depends = ros-lunar-actionlib-msgs
+ depends = boost
+ source = ros-lunar-actionlib-1.11.9-0.tar.gz::https://github.com/ros-gbp/actionlib-release/archive/release/lunar/actionlib/1.11.9-0.tar.gz
+ sha256sums = fb0081a243e50a7514f8b4da04125386b65bad59aa6183502001ec9345177c30
+
+pkgname = ros-lunar-actionlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b661a6dbaf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The actionlib stack provides a standardized interface for interfacing with preemptable tasks."
+url='http://www.ros.org/wiki/actionlib'
+
+pkgname='ros-lunar-actionlib'
+pkgver='1.11.9'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-roscpp
+ ros-lunar-rospy
+ ros-lunar-std-msgs
+ ros-lunar-rostest
+ ros-lunar-message-generation
+ ros-lunar-actionlib-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-lunar-roscpp
+ ros-lunar-rospy
+ ros-lunar-std-msgs
+ ros-lunar-rostest
+ ros-lunar-message-runtime
+ ros-lunar-actionlib-msgs)
+depends=(${ros_depends[@]}
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/actionlib/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/actionlib-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="actionlib-release-release-lunar-actionlib-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/actionlib-release/archive/release/lunar/actionlib/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('fb0081a243e50a7514f8b4da04125386b65bad59aa6183502001ec9345177c30')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}