summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:41:16 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commit85ca1942b7f48f0150fbd23fd2fc451c298182db (patch)
tree678285ff999d6cf06d1e1d88606a43d9473e3570
downloadaur-85ca1942b7f48f0150fbd23fd2fc451c298182db.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD69
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac647b5df59d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:35 UTC 2017
+pkgbase = ros-lunar-bondcpp
+ pkgdesc = ROS - C++ implementation of bond, a mechanism for checking when another process has terminated.
+ pkgver = 1.7.19
+ pkgrel = 1
+ url = http://www.ros.org/wiki/bondcpp
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-cmake-modules
+ makedepends = ros-lunar-roscpp
+ makedepends = ros-lunar-smclib
+ makedepends = ros-lunar-bond
+ makedepends = util-linux
+ makedepends = boost
+ depends = ros-lunar-roscpp
+ depends = ros-lunar-smclib
+ depends = ros-lunar-bond
+ depends = util-linux
+ depends = boost
+ source = ros-lunar-bondcpp-1.7.19-0.tar.gz::https://github.com/ros-gbp/bond_core-release/archive/release/lunar/bondcpp/1.7.19-0.tar.gz
+ sha256sums = dbf64fb9164560d5a93d9be51b811d2575297e8fc7fb66e532a84317061657d6
+
+pkgname = ros-lunar-bondcpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..329453be4001
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - C++ implementation of bond, a mechanism for checking when another process has terminated."
+url='http://www.ros.org/wiki/bondcpp'
+
+pkgname='ros-lunar-bondcpp'
+pkgver='1.7.19'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-cmake-modules
+ ros-lunar-roscpp
+ ros-lunar-smclib
+ ros-lunar-bond)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ util-linux
+ boost)
+
+ros_depends=(ros-lunar-roscpp
+ ros-lunar-smclib
+ ros-lunar-bond)
+depends=(${ros_depends[@]}
+ util-linux
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/bondcpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="bond_core-release-release-lunar-bondcpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/lunar/bondcpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('dbf64fb9164560d5a93d9be51b811d2575297e8fc7fb66e532a84317061657d6')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}