summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 11:18:17 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commitae6e18778ef7b05df1e64d74df1b7edbfc2de777 (patch)
tree3f7538cd5f9bef76f6b5b9922cf27a3da6a1d4e0
downloadaur-ros-lunar-image-transport-plugins.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD61
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0989afa31896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:30 UTC 2017
+pkgbase = ros-lunar-image-transport-plugins
+ pkgdesc = ROS - A set of plugins for publishing and subscribing to sensor_msgs/Image topics in representations other than raw pixel data.
+ pkgver = 1.9.5
+ pkgrel = 1
+ url = http://www.ros.org/wiki/image_transport_plugins
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-theora-image-transport
+ depends = ros-lunar-compressed-image-transport
+ depends = ros-lunar-compressed-depth-image-transport
+ source = ros-lunar-image-transport-plugins-1.9.5-0.tar.gz::https://github.com/ros-gbp/image_transport_plugins-release/archive/release/lunar/image_transport_plugins/1.9.5-0.tar.gz
+ sha256sums = af224372ff5e069e03f1e960d544b2d5cd595eaf2c6f27cf4b86696088f4ee73
+
+pkgname = ros-lunar-image-transport-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a2a39acd233
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A set of plugins for publishing and subscribing to sensor_msgs/Image topics in representations other than raw pixel data."
+url='http://www.ros.org/wiki/image_transport_plugins'
+
+pkgname='ros-lunar-image-transport-plugins'
+pkgver='1.9.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-theora-image-transport
+ ros-lunar-compressed-image-transport
+ ros-lunar-compressed-depth-image-transport)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/image_transport_plugins/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/image_transport_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="image_transport_plugins-release-release-lunar-image_transport_plugins-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/image_transport_plugins-release/archive/release/lunar/image_transport_plugins/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('af224372ff5e069e03f1e960d544b2d5cd595eaf2c6f27cf4b86696088f4ee73')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}