summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-11-12 17:21:40 +0100
committerTim Rakowski2017-11-12 17:21:40 +0100
commit128bdf13c03af2f92dcc907b0c56ea97f8544a80 (patch)
tree04bc85cb94d38684e7ee378affa3aa4288c0b9cc
parent1a5a908a3d39dc9e9a596dcb27f0ccac8dc54f45 (diff)
downloadaur-128bdf13c03af2f92dcc907b0c56ea97f8544a80.tar.gz
Update to version 1.11.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29febbabcdba..20986f53c231 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 10:47:39 UTC 2017
+# Sun Nov 12 16:15:24 UTC 2017
pkgbase = ros-lunar-pluginlib
pkgdesc = ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.
- pkgver = 1.11.0
+ pkgver = 1.11.1
pkgrel = 1
url = http://www.ros.org/wiki/pluginlib
arch = any
@@ -11,18 +11,13 @@ pkgbase = ros-lunar-pluginlib
makedepends = ros-build-tools
makedepends = ros-lunar-catkin
makedepends = ros-lunar-cmake-modules
- makedepends = ros-lunar-roslib
- makedepends = ros-lunar-class-loader
- makedepends = ros-lunar-rosconsole
- makedepends = tinyxml2
- makedepends = boost
depends = ros-lunar-class-loader
depends = ros-lunar-roslib
depends = ros-lunar-rosconsole
depends = tinyxml2
depends = boost
- source = ros-lunar-pluginlib-1.11.0-0.tar.gz::https://github.com/ros-gbp/pluginlib-release/archive/release/lunar/pluginlib/1.11.0-0.tar.gz
- sha256sums = 80f12a589133f55cfba980f52d806c55f10d6cde3353a6c142414403eb5db483
+ source = ros-lunar-pluginlib-1.11.1-0.tar.gz::https://github.com/ros-gbp/pluginlib-release/archive/release/lunar/pluginlib/1.11.1-0.tar.gz
+ sha256sums = ff5b465e6290d95e090892f3c11a72b1270e3bd177ee7f55336d6ddf4d4082f1
pkgname = ros-lunar-pluginlib
diff --git a/PKGBUILD b/PKGBUILD
index d7588cf4638d..7c2d7d59f344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,16 @@ pkgdesc="ROS - The pluginlib package provides tools for writing and dynamically
url='http://www.ros.org/wiki/pluginlib'
pkgname='ros-lunar-pluginlib'
-pkgver='1.11.0'
+pkgver='1.11.1'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-lunar-catkin
- ros-lunar-cmake-modules
- ros-lunar-roslib
- ros-lunar-class-loader
- ros-lunar-rosconsole)
+ ros-lunar-cmake-modules)
makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- tinyxml2
- boost)
+ ${ros_makedepends[@]})
ros_depends=(ros-lunar-class-loader
ros-lunar-roslib
@@ -27,6 +22,9 @@ depends=(${ros_depends[@]}
tinyxml2
boost)
+ros_checkdepends=()
+checkdepends=(${ros_checkdepends[@]})
+
# Git version (e.g. for debugging)
# _tag=release/lunar/pluginlib/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
@@ -36,7 +34,7 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="pluginlib-release-release-lunar-pluginlib-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/pluginlib-release/archive/release/lunar/pluginlib/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('80f12a589133f55cfba980f52d806c55f10d6cde3353a6c142414403eb5db483')
+sha256sums=('ff5b465e6290d95e090892f3c11a72b1270e3bd177ee7f55336d6ddf4d4082f1')
build() {
# Use ROS environment variables
@@ -44,14 +42,14 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
@@ -59,7 +57,8 @@ build() {
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
make
}