summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:41:37 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit9da029e97548cad64eb531fc4ba3dce271104e7c (patch)
tree09ae067a4da0989e6a4a10e639823173ffedef72
downloadaur-9da029e97548cad64eb531fc4ba3dce271104e7c.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD69
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4ab21c6d840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:30 UTC 2017
+pkgbase = ros-lunar-pluginlib
+ pkgdesc = ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.
+ pkgver = 1.10.5
+ pkgrel = 1
+ url = http://www.ros.org/wiki/pluginlib
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-cmake-modules
+ makedepends = ros-lunar-roslib
+ makedepends = ros-lunar-class-loader
+ makedepends = ros-lunar-rosconsole
+ makedepends = boost
+ makedepends = tinyxml
+ depends = ros-lunar-class-loader
+ depends = ros-lunar-roslib
+ depends = ros-lunar-rosconsole
+ depends = boost
+ depends = tinyxml
+ source = ros-lunar-pluginlib-1.10.5-0.tar.gz::https://github.com/ros-gbp/pluginlib-release/archive/release/lunar/pluginlib/1.10.5-0.tar.gz
+ sha256sums = 52757ac820e93b77a2151428c44099b7b0a995d7e1480a99105679e944f83daa
+
+pkgname = ros-lunar-pluginlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c57755f4950c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure."
+url='http://www.ros.org/wiki/pluginlib'
+
+pkgname='ros-lunar-pluginlib'
+pkgver='1.10.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-cmake-modules
+ ros-lunar-roslib
+ ros-lunar-class-loader
+ ros-lunar-rosconsole)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ tinyxml)
+
+ros_depends=(ros-lunar-class-loader
+ ros-lunar-roslib
+ ros-lunar-rosconsole)
+depends=(${ros_depends[@]}
+ boost
+ tinyxml)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/pluginlib/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/pluginlib-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="pluginlib-release-release-lunar-pluginlib-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/pluginlib-release/archive/release/lunar/pluginlib/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('52757ac820e93b77a2151428c44099b7b0a995d7e1480a99105679e944f83daa')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}