summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:44:51 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commit1f31482e0ad656a0c09d962625d492676f8f693d (patch)
tree041abbde40091b31f745bbebb91680c4078f1a1c
downloadaur-1f31482e0ad656a0c09d962625d492676f8f693d.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD66
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3876ae8a464f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:34 UTC 2017
+pkgbase = ros-lunar-robot-model
+ pkgdesc = ROS - robot_model contains packages for modeling various aspects of robot information, specified in the Xml Robot Description Format (URDF).
+ pkgver = 1.12.9
+ pkgrel = 1
+ url = http://ros.org/wiki/robot_model
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-joint-state-publisher
+ depends = ros-lunar-resource-retriever
+ depends = ros-lunar-collada-urdf
+ depends = ros-lunar-urdf
+ depends = ros-lunar-collada-parser
+ depends = ros-lunar-kdl-parser
+ depends = ros-lunar-urdf-parser-plugin
+ depends = urdfdom
+ source = ros-lunar-robot-model-1.12.9-0.tar.gz::https://github.com/ros-gbp/robot_model-release/archive/release/lunar/robot_model/1.12.9-0.tar.gz
+ sha256sums = 30579517c45979bbfa3dece4c4ca1479e43eed12ee2b38d585b19b1341f0411c
+
+pkgname = ros-lunar-robot-model
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f3653b0d356
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - robot_model contains packages for modeling various aspects of robot information, specified in the Xml Robot Description Format (URDF)."
+url='http://ros.org/wiki/robot_model'
+
+pkgname='ros-lunar-robot-model'
+pkgver='1.12.9'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-joint-state-publisher
+ ros-lunar-resource-retriever
+ ros-lunar-collada-urdf
+ ros-lunar-urdf
+ ros-lunar-collada-parser
+ ros-lunar-kdl-parser
+ ros-lunar-urdf-parser-plugin)
+depends=(${ros_depends[@]}
+ urdfdom)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/robot_model/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/robot_model-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="robot_model-release-release-lunar-robot_model-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/robot_model-release/archive/release/lunar/robot_model/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('30579517c45979bbfa3dece4c4ca1479e43eed12ee2b38d585b19b1341f0411c')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}