summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:40:53 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commit7bde67bfbbbbae648c761c6e029317db8960e035 (patch)
treec0d4fdb16b662a9d0aad8d531a090f5da420590e
downloadaur-7bde67bfbbbbae648c761c6e029317db8960e035.tar.gz
Initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD79
2 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..773b673c8938
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:30 UTC 2017
+pkgbase = ros-lunar-ros-core
+ pkgdesc = ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-rosconsole-bridge
+ depends = ros-lunar-gencpp
+ depends = ros-lunar-catkin
+ depends = ros-lunar-common-msgs
+ depends = ros-lunar-gennodejs
+ depends = ros-lunar-genmsg
+ depends = ros-lunar-genlisp
+ depends = ros-lunar-roscpp-core
+ depends = ros-lunar-geneus
+ depends = ros-lunar-rospack
+ depends = ros-lunar-rosgraph-msgs
+ depends = ros-lunar-std-srvs
+ depends = ros-lunar-rosbag-migration-rule
+ depends = ros-lunar-ros-comm
+ depends = ros-lunar-roslisp
+ depends = ros-lunar-cmake-modules
+ depends = ros-lunar-std-msgs
+ depends = ros-lunar-genpy
+ depends = ros-lunar-message-runtime
+ depends = ros-lunar-message-generation
+ depends = ros-lunar-ros
+ source = ros-lunar-ros-core-1.3.1-0.tar.gz::https://github.com/ros-gbp/metapackages-release/archive/release/lunar/ros_core/1.3.1-0.tar.gz
+ sha256sums = 5a7d1db4bc048216d5fb0552b3c1ed3fc33a178186e4bc6609cf61684ad7aa6d
+
+pkgname = ros-lunar-ros-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b8cd119f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts."
+url='http://www.ros.org/'
+
+pkgname='ros-lunar-ros-core'
+pkgver='1.3.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-rosconsole-bridge
+ ros-lunar-gencpp
+ ros-lunar-catkin
+ ros-lunar-common-msgs
+ ros-lunar-gennodejs
+ ros-lunar-genmsg
+ ros-lunar-genlisp
+ ros-lunar-roscpp-core
+ ros-lunar-geneus
+ ros-lunar-rospack
+ ros-lunar-rosgraph-msgs
+ ros-lunar-std-srvs
+ ros-lunar-rosbag-migration-rule
+ ros-lunar-ros-comm
+ ros-lunar-roslisp
+ ros-lunar-cmake-modules
+ ros-lunar-std-msgs
+ ros-lunar-genpy
+ ros-lunar-message-runtime
+ ros-lunar-message-generation
+ ros-lunar-ros)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/ros_core/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="metapackages-release-release-lunar-ros_core-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/metapackages-release/archive/release/lunar/ros_core/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('5a7d1db4bc048216d5fb0552b3c1ed3fc33a178186e4bc6609cf61684ad7aa6d')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}