summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:39:57 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commitc1bf642c2ac88a42f5d140cebed303e8062c4cbe (patch)
treed0f7c46e4169a8c327aa9b97fccaf365c8ac12c8
downloadaur-c1bf642c2ac88a42f5d140cebed303e8062c4cbe.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD74
2 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bca21cbd32bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:37 UTC 2017
+pkgbase = ros-lunar-rosbag-storage
+ pkgdesc = ROS - This is a set of tools for recording from and playing back ROS message without relying on the ROS client library.
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-roscpp-serialization
+ makedepends = ros-lunar-rostime
+ makedepends = ros-lunar-cpp-common
+ makedepends = ros-lunar-roslz4
+ makedepends = ros-lunar-roscpp-traits
+ makedepends = bzip2
+ makedepends = boost
+ makedepends = console-bridge
+ depends = ros-lunar-rostime
+ depends = ros-lunar-cpp-common
+ depends = ros-lunar-roscpp-traits
+ depends = ros-lunar-roslz4
+ depends = ros-lunar-roscpp-serialization
+ depends = bzip2
+ depends = boost
+ depends = console-bridge
+ source = ros-lunar-rosbag-storage-1.13.0-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rosbag_storage/1.13.0-0.tar.gz
+ sha256sums = 472da59307a47547c95397dfb6ab76d31518ed736089ea7dec699a7892079f3e
+
+pkgname = ros-lunar-rosbag-storage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e65c019470c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This is a set of tools for recording from and playing back ROS message without relying on the ROS client library."
+url='http://www.ros.org/'
+
+pkgname='ros-lunar-rosbag-storage'
+pkgver='1.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-roscpp-serialization
+ ros-lunar-rostime
+ ros-lunar-cpp-common
+ ros-lunar-roslz4
+ ros-lunar-roscpp-traits)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ bzip2
+ boost
+ console-bridge)
+
+ros_depends=(ros-lunar-rostime
+ ros-lunar-cpp-common
+ ros-lunar-roscpp-traits
+ ros-lunar-roslz4
+ ros-lunar-roscpp-serialization)
+depends=(${ros_depends[@]}
+ bzip2
+ boost
+ console-bridge)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rosbag_storage/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-lunar-rosbag_storage-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rosbag_storage/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('472da59307a47547c95397dfb6ab76d31518ed736089ea7dec699a7892079f3e')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}