summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:50:16 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commitfeb6096caaa7d10b017a7204462558941b2ead69 (patch)
treebae6da4f4ca5676c7ad159da992e93e9a3df61ca
downloadaur-feb6096caaa7d10b017a7204462558941b2ead69.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e425ccb8b431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:36 UTC 2017
+pkgbase = ros-lunar-rospy-tutorials
+ pkgdesc = ROS - This package attempts to show the features of ROS python API step-by-step, including using messages, servers, parameters, etc.
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://www.ros.org/wiki/rospy_tutorials
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-std-msgs
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-message-generation
+ makedepends = ros-lunar-rostest
+ depends = ros-lunar-message-runtime
+ depends = ros-lunar-std-msgs
+ depends = ros-lunar-rospy
+ source = ros-lunar-rospy-tutorials-0.8.0-0.tar.gz::https://github.com/ros-gbp/ros_tutorials-release/archive/release/lunar/rospy_tutorials/0.8.0-0.tar.gz
+ sha256sums = 03e2ce137e0f5aabf72886cbbd38bc4718a9d74951911295070e9a21b35ab81a
+
+pkgname = ros-lunar-rospy-tutorials
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e743fe837e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package attempts to show the features of ROS python API step-by-step, including using messages, servers, parameters, etc."
+url='http://www.ros.org/wiki/rospy_tutorials'
+
+pkgname='ros-lunar-rospy-tutorials'
+pkgver='0.8.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-std-msgs
+ ros-lunar-catkin
+ ros-lunar-message-generation
+ ros-lunar-rostest)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-message-runtime
+ ros-lunar-std-msgs
+ ros-lunar-rospy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rospy_tutorials/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_tutorials-release-release-lunar-rospy_tutorials-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_tutorials-release/archive/release/lunar/rospy_tutorials/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('03e2ce137e0f5aabf72886cbbd38bc4718a9d74951911295070e9a21b35ab81a')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}