summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:37:18 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit15396aa73594cb81e2901165329fdbaadb77ad1d (patch)
treed74623c7f45975a78e029450cc83af74e03c2000
downloadaur-15396aa73594cb81e2901165329fdbaadb77ad1d.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03ab37609bf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:32 UTC 2017
+pkgbase = ros-lunar-rostime
+ pkgdesc = ROS - Time and Duration implementations for C++ libraries, including roscpp.
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = http://ros.org/wiki/rostime
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-cpp-common
+ makedepends = boost
+ depends = ros-lunar-cpp-common
+ depends = boost
+ source = ros-lunar-rostime-0.6.3-0.tar.gz::https://github.com/ros-gbp/roscpp_core-release/archive/release/lunar/rostime/0.6.3-0.tar.gz
+ sha256sums = 2ca5b01d71166f98c38825450ef1575d1afa3d06762d8f230ee04cadb2ed069a
+
+pkgname = ros-lunar-rostime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bac64edf6de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Time and Duration implementations for C++ libraries, including roscpp."
+url='http://ros.org/wiki/rostime'
+
+pkgname='ros-lunar-rostime'
+pkgver='0.6.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-cpp-common)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-lunar-cpp-common)
+depends=(${ros_depends[@]}
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rostime/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="roscpp_core-release-release-lunar-rostime-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roscpp_core-release/archive/release/lunar/rostime/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2ca5b01d71166f98c38825450ef1575d1afa3d06762d8f230ee04cadb2ed069a')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}