summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-08-17 20:57:56 +0200
committerTim Rakowski2017-08-17 20:57:56 +0200
commitedf43ab28bcee1d02de44a0138e4db4bcb839bb0 (patch)
treed46bbe9d086e368ddb138c45cbb67577f9c3b408
parent02fe7193f00306120e46a894c2b4e843c47a80c8 (diff)
downloadaur-edf43ab28bcee1d02de44a0138e4db4bcb839bb0.tar.gz
Update to version 1.13.2-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba690749355c..49d3c65559e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 10:47:44 UTC 2017
+# Thu Aug 17 18:55:06 UTC 2017
pkgbase = ros-lunar-rostopic
pkgdesc = ROS - rostopic contains the rostopic command-line tool for displaying debug information about ROS Topics, including publishers, subscribers, publishing rate, and ROS Messages.
- pkgver = 1.13.1
+ pkgver = 1.13.2
pkgrel = 1
url = http://ros.org/wiki/rostopic
arch = any
@@ -14,8 +14,8 @@ pkgbase = ros-lunar-rostopic
depends = ros-lunar-genpy
depends = ros-lunar-rosbag
depends = ros-lunar-rospy
- source = ros-lunar-rostopic-1.13.1-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rostopic/1.13.1-0.tar.gz
- sha256sums = a6bb8565b8797e1cece6e908a41941bf4283ee038e8b435a723d9a8fb0b32adf
+ source = ros-lunar-rostopic-1.13.2-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rostopic/1.13.2-0.tar.gz
+ sha256sums = b1f4e0551cad3d350713e478a7a59c6d4da106d6d2655a4e0f7f0fc1c98c2b5f
pkgname = ros-lunar-rostopic
diff --git a/PKGBUILD b/PKGBUILD
index e3927c33cb5d..f76aed9e44f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - rostopic contains the rostopic command-line tool for displaying d
url='http://ros.org/wiki/rostopic'
pkgname='ros-lunar-rostopic'
-pkgver='1.13.1'
+pkgver='1.13.2'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -29,7 +29,7 @@ depends=(${ros_depends[@]})
# Tarball version (faster download)
_dir="ros_comm-release-release-lunar-rostopic-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rostopic/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('a6bb8565b8797e1cece6e908a41941bf4283ee038e8b435a723d9a8fb0b32adf')
+sha256sums=('b1f4e0551cad3d350713e478a7a59c6d4da106d6d2655a4e0f7f0fc1c98c2b5f')
build() {
# Use ROS environment variables
@@ -37,14 +37,14 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \