summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:46:24 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commit0e282683811f2d8e0b2ee2a18a78c54d194026b6 (patch)
tree780aeda7b43c18b98bdc350d49f734cfa7ddd40d
downloadaur-ros-lunar-rqt-dep.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD65
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cf7acc2ddfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:29 UTC 2017
+pkgbase = ros-lunar-rqt-dep
+ pkgdesc = ROS - rqt_dep provides a GUI plugin for visualizing the ROS dependency graph.
+ pkgver = 0.4.8
+ pkgrel = 1
+ url = http://wiki.ros.org/rqt_dep
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-qt-gui
+ depends = ros-lunar-qt-gui-py-common
+ depends = ros-lunar-rqt-graph
+ depends = ros-lunar-qt-dotgraph
+ depends = ros-lunar-python-qt-binding
+ depends = ros-lunar-rqt-gui-py
+ depends = python2-rospkg
+ source = ros-lunar-rqt-dep-0.4.8-0.tar.gz::https://github.com/ros-gbp/rqt_dep-release/archive/release/lunar/rqt_dep/0.4.8-0.tar.gz
+ sha256sums = ec3227b0dc67dac62e83da5ea4c81792aecaf421e8cece88ce59e3bac9d4da73
+
+pkgname = ros-lunar-rqt-dep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c388884a5954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_dep provides a GUI plugin for visualizing the ROS dependency graph."
+url='http://wiki.ros.org/rqt_dep'
+
+pkgname='ros-lunar-rqt-dep'
+pkgver='0.4.8'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-qt-gui
+ ros-lunar-qt-gui-py-common
+ ros-lunar-rqt-graph
+ ros-lunar-qt-dotgraph
+ ros-lunar-python-qt-binding
+ ros-lunar-rqt-gui-py)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rqt_dep/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_dep-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_dep-release-release-lunar-rqt_dep-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_dep-release/archive/release/lunar/rqt_dep/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ec3227b0dc67dac62e83da5ea4c81792aecaf421e8cece88ce59e3bac9d4da73')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}