summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:47:50 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commit7f64aa83cba31dae9094e9223be084e9caf92a31 (patch)
tree9855cd91fe09059208d38d9bc531e2a52231aad7
downloadaur-7f64aa83cba31dae9094e9223be084e9caf92a31.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..488390071f6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:37 UTC 2017
+pkgbase = ros-lunar-rqt-shell
+ pkgdesc = ROS - rqt_shell is a Python GUI plugin providing an interactive shell.
+ pkgver = 0.4.8
+ pkgrel = 1
+ url = http://wiki.ros.org/rqt_shell
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-qt-gui
+ depends = ros-lunar-python-qt-binding
+ depends = ros-lunar-rqt-gui-py
+ depends = ros-lunar-rqt-gui
+ depends = ros-lunar-qt-gui-py-common
+ depends = python2-rospkg
+ source = ros-lunar-rqt-shell-0.4.8-0.tar.gz::https://github.com/ros-gbp/rqt_shell-release/archive/release/lunar/rqt_shell/0.4.8-0.tar.gz
+ sha256sums = bc6a1761519871a4f5f45b79a8b7eccc18133a123b77154f983d230b05e39cc3
+
+pkgname = ros-lunar-rqt-shell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb0b38a5ecf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_shell is a Python GUI plugin providing an interactive shell."
+url='http://wiki.ros.org/rqt_shell'
+
+pkgname='ros-lunar-rqt-shell'
+pkgver='0.4.8'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-qt-gui
+ ros-lunar-python-qt-binding
+ ros-lunar-rqt-gui-py
+ ros-lunar-rqt-gui
+ ros-lunar-qt-gui-py-common)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rqt_shell/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_shell-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_shell-release-release-lunar-rqt_shell-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_shell-release/archive/release/lunar/rqt_shell/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('bc6a1761519871a4f5f45b79a8b7eccc18133a123b77154f983d230b05e39cc3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}