summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2018-01-04 23:03:15 +0100
committerTim Rakowski2018-01-04 23:03:15 +0100
commit49936febd6b5c679ba18261b3ccfa42a9c1eed1d (patch)
treefeefc8f17f47d0cc24665c1286652982a28dd11b
parentaebe931ed04788c25ceb5c57ccb6c8d9a186d215 (diff)
downloadaur-ros-lunar-tf2.tar.gz
Update to version 0.5.17-1
- Also added patch for logWarn/logError changes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--logError_fix.patch97
3 files changed, 124 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a224c65c049..22552fdbb715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
# Generated by mksrcinfo v8
-# Mon Aug 7 18:25:05 UTC 2017
+# Thu Jan 4 22:02:23 UTC 2018
pkgbase = ros-lunar-tf2
pkgdesc = ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time.
- pkgver = 0.5.16
+ pkgver = 0.5.17
pkgrel = 1
url = http://www.ros.org/wiki/tf2
arch = any
license = BSD
+ makedepends = ros-lunar-catkin
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-lunar-rostime
- makedepends = ros-lunar-catkin
- makedepends = ros-lunar-geometry-msgs
- makedepends = ros-lunar-tf2-msgs
- makedepends = console-bridge
depends = ros-lunar-rostime
depends = ros-lunar-geometry-msgs
depends = ros-lunar-tf2-msgs
depends = console-bridge
- source = ros-lunar-tf2-0.5.16-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2/0.5.16-0.tar.gz
- sha256sums = 5c3731bd35d64a15cc8f935aef430f12424f23eca239f5474df2f036d4ca1d77
+ source = ros-lunar-tf2-0.5.17-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2/0.5.17-0.tar.gz
+ source = logError_fix.patch
+ sha256sums = e839887d44a5d1fa48cce5a287d061a7beb262595b25d6b8e038deca2660f12f
+ sha256sums = e3238a399b4e740ffc1f5a67d66fa67d183144f2a2c227251dabe008094ea548
pkgname = ros-lunar-tf2
diff --git a/PKGBUILD b/PKGBUILD
index 3b8a80723efa..2ef51d4ecbd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,16 @@ pkgdesc="ROS - tf2 is the second generation of the transform library, which lets
url='http://www.ros.org/wiki/tf2'
pkgname='ros-lunar-tf2'
-pkgver='0.5.16'
+pkgver='0.5.17'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-lunar-rostime
- ros-lunar-catkin
- ros-lunar-geometry-msgs
- ros-lunar-tf2-msgs)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- console-bridge)
+ros_makedepends=(ros-lunar-catkin)
+makedepends=(${ros_makedepends[@]}
+ cmake
+ ros-build-tools)
ros_depends=(ros-lunar-rostime
ros-lunar-geometry-msgs
@@ -32,8 +29,14 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="geometry2-release-release-lunar-tf2-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('5c3731bd35d64a15cc8f935aef430f12424f23eca239f5474df2f036d4ca1d77')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2/${pkgver}-${_pkgver_patch}.tar.gz" "logError_fix.patch")
+sha256sums=('e839887d44a5d1fa48cce5a287d061a7beb262595b25d6b8e038deca2660f12f'
+ 'e3238a399b4e740ffc1f5a67d66fa67d183144f2a2c227251dabe008094ea548')
+
+prepare() {
+ cd "${srcdir}"
+ patch -Np1 -i "logError_fix.patch"
+}
build() {
# Use ROS environment variables
@@ -41,22 +44,24 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DCMAKE_PREFIX_PATH=/opt/ros/lunar \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
make
}
diff --git a/logError_fix.patch b/logError_fix.patch
new file mode 100644
index 000000000000..ac1ca4e50742
--- /dev/null
+++ b/logError_fix.patch
@@ -0,0 +1,97 @@
+diff -ura original/geometry2-release-release-lunar-tf2-0.5.17-0/src/buffer_core.cpp patched/geometry2-release-release-lunar-tf2-0.5.17-0/src/buffer_core.cpp
+--- original/geometry2-release-release-lunar-tf2-0.5.17-0/src/buffer_core.cpp 2018-01-02 07:46:40.000000000 +0100
++++ patched/geometry2-release-release-lunar-tf2-0.5.17-0/src/buffer_core.cpp 2018-01-04 23:00:01.622880799 +0100
+@@ -123,7 +123,7 @@
+ {
+ std::stringstream ss;
+ ss << "Invalid argument passed to "<< function_name_arg <<" in tf2 frame_ids cannot be empty";
+- logWarn("%s",ss.str().c_str());
++ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
+ return true;
+ }
+
+@@ -131,7 +131,7 @@
+ {
+ std::stringstream ss;
+ ss << "Invalid argument \"" << frame_id << "\" passed to "<< function_name_arg <<" in tf2 frame_ids cannot start with a '/' like: ";
+- logWarn("%s",ss.str().c_str());
++ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
+ return true;
+ }
+
+@@ -218,26 +218,26 @@
+ bool error_exists = false;
+ if (stripped.child_frame_id == stripped.header.frame_id)
+ {
+- logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
++ CONSOLE_BRIDGE_logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
+ error_exists = true;
+ }
+
+ if (stripped.child_frame_id == "")
+ {
+- logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
++ CONSOLE_BRIDGE_logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
+ error_exists = true;
+ }
+
+ if (stripped.header.frame_id == "")
+ {
+- logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
++ CONSOLE_BRIDGE_logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
+ error_exists = true;
+ }
+
+ if (std::isnan(stripped.transform.translation.x) || std::isnan(stripped.transform.translation.y) || std::isnan(stripped.transform.translation.z)||
+ std::isnan(stripped.transform.rotation.x) || std::isnan(stripped.transform.rotation.y) || std::isnan(stripped.transform.rotation.z) || std::isnan(stripped.transform.rotation.w))
+ {
+- logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
++ CONSOLE_BRIDGE_logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
+ stripped.child_frame_id.c_str(), authority.c_str(),
+ stripped.transform.translation.x, stripped.transform.translation.y, stripped.transform.translation.z,
+ stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w
+@@ -252,7 +252,7 @@
+
+ if (!valid)
+ {
+- logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
++ CONSOLE_BRIDGE_logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
+ stripped.child_frame_id.c_str(), authority.c_str(),
+ stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w);
+ error_exists = true;
+@@ -274,7 +274,7 @@
+ }
+ else
+ {
+- logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
++ CONSOLE_BRIDGE_logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
+ return false;
+ }
+ }
+@@ -633,7 +633,7 @@
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }
+@@ -1604,7 +1604,7 @@
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }
+@@ -1623,7 +1623,7 @@
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }