summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 11:18:45 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commitf4f567ae389247e13df09292c0f53b39a4fa4c09 (patch)
tree4571ea23d08970b91a9954d1ed3761ae20900331
downloadaur-f4f567ae389247e13df09292c0f53b39a4fa4c09.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD65
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12f0d1049d8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:34 UTC 2017
+pkgbase = ros-lunar-tf2-eigen
+ pkgdesc = ROS - tf2_eigen.
+ pkgver = 0.5.15
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-tf2
+ makedepends = ros-lunar-cmake-modules
+ makedepends = ros-lunar-geometry-msgs
+ makedepends = ros-lunar-catkin
+ makedepends = eigen3
+ depends = ros-lunar-tf2
+ depends = ros-lunar-cmake-modules
+ depends = ros-lunar-geometry-msgs
+ source = ros-lunar-tf2-eigen-0.5.15-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2_eigen/0.5.15-0.tar.gz
+ sha256sums = ff86c6d6752c86a2ada471dec61ff86084c3fa0e54fd30e9e989075f80ce4737
+
+pkgname = ros-lunar-tf2-eigen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fa6b081aa13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - tf2_eigen."
+url='http://www.ros.org/'
+
+pkgname='ros-lunar-tf2-eigen'
+pkgver='0.5.15'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-tf2
+ ros-lunar-cmake-modules
+ ros-lunar-geometry-msgs
+ ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ eigen3)
+
+ros_depends=(ros-lunar-tf2
+ ros-lunar-cmake-modules
+ ros-lunar-geometry-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/tf2_eigen/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="geometry2-release-release-lunar-tf2_eigen-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2_eigen/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ff86c6d6752c86a2ada471dec61ff86084c3fa0e54fd30e9e989075f80ce4737')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}