summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:42:28 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commita94f330cfd83e32b3cb0922f439fa01fe0eed415 (patch)
tree3b7c08db95bfc25a7a8b523572743189dbe4ec3d
downloadaur-a94f330cfd83e32b3cb0922f439fa01fe0eed415.tar.gz
Initial commit
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD82
2 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c70c4a9d06f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:30 UTC 2017
+pkgbase = ros-lunar-tf2-ros
+ pkgdesc = ROS - This package contains the ROS bindings for the tf2 library, for both Python and C++.
+ pkgver = 0.5.15
+ pkgrel = 1
+ url = http://www.ros.org/wiki/tf2_ros
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-actionlib
+ makedepends = ros-lunar-tf2
+ makedepends = ros-lunar-message-filters
+ makedepends = ros-lunar-roscpp
+ makedepends = ros-lunar-rosgraph
+ makedepends = ros-lunar-tf2-py
+ makedepends = ros-lunar-xmlrpcpp
+ makedepends = ros-lunar-rospy
+ makedepends = ros-lunar-geometry-msgs
+ makedepends = ros-lunar-std-msgs
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-tf2-msgs
+ makedepends = ros-lunar-actionlib-msgs
+ depends = ros-lunar-actionlib
+ depends = ros-lunar-tf2
+ depends = ros-lunar-message-filters
+ depends = ros-lunar-roscpp
+ depends = ros-lunar-rosgraph
+ depends = ros-lunar-tf2-py
+ depends = ros-lunar-xmlrpcpp
+ depends = ros-lunar-rospy
+ depends = ros-lunar-geometry-msgs
+ depends = ros-lunar-std-msgs
+ depends = ros-lunar-tf2-msgs
+ depends = ros-lunar-actionlib-msgs
+ source = ros-lunar-tf2-ros-0.5.15-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2_ros/0.5.15-0.tar.gz
+ sha256sums = 36fa9ee0df5424cacec126d41283775b126b3f57a41cb8e37a4fb45bad9abcf3
+
+pkgname = ros-lunar-tf2-ros
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb9c21785211
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package contains the ROS bindings for the tf2 library, for both Python and C++."
+url='http://www.ros.org/wiki/tf2_ros'
+
+pkgname='ros-lunar-tf2-ros'
+pkgver='0.5.15'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-actionlib
+ ros-lunar-tf2
+ ros-lunar-message-filters
+ ros-lunar-roscpp
+ ros-lunar-rosgraph
+ ros-lunar-tf2-py
+ ros-lunar-xmlrpcpp
+ ros-lunar-rospy
+ ros-lunar-geometry-msgs
+ ros-lunar-std-msgs
+ ros-lunar-catkin
+ ros-lunar-tf2-msgs
+ ros-lunar-actionlib-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-actionlib
+ ros-lunar-tf2
+ ros-lunar-message-filters
+ ros-lunar-roscpp
+ ros-lunar-rosgraph
+ ros-lunar-tf2-py
+ ros-lunar-xmlrpcpp
+ ros-lunar-rospy
+ ros-lunar-geometry-msgs
+ ros-lunar-std-msgs
+ ros-lunar-tf2-msgs
+ ros-lunar-actionlib-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/tf2_ros/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="geometry2-release-release-lunar-tf2_ros-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/lunar/tf2_ros/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('36fa9ee0df5424cacec126d41283775b126b3f57a41cb8e37a4fb45bad9abcf3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}