summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-12-12 21:51:25 +0100
committerTim Rakowski2017-12-12 21:51:25 +0100
commitc8cb7768aff79dc0b7a97dc5ec421eeda3a92e9a (patch)
treea0ed2002e480897e00aed28d9da21bc39c884e82
parentf539f76820d2c1400268afed189ca5c75d7b3d73 (diff)
downloadaur-ros-lunar-urdf-parser-plugin.tar.gz
Update to version 1.12.12-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a430569d4fe..f8f03b39c038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 10:47:38 UTC 2017
+# Tue Dec 12 20:47:21 UTC 2017
pkgbase = ros-lunar-urdf-parser-plugin
pkgdesc = ROS - This package contains a C++ base class for URDF parsers.
- pkgver = 1.12.11
+ pkgver = 1.12.12
pkgrel = 1
url = http://ros.org/wiki/urdf
arch = any
@@ -10,10 +10,9 @@ pkgbase = ros-lunar-urdf-parser-plugin
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-lunar-catkin
- makedepends = urdfdom-headers
depends = urdfdom-headers
- source = ros-lunar-urdf-parser-plugin-1.12.11-0.tar.gz::https://github.com/ros-gbp/robot_model-release/archive/release/lunar/urdf_parser_plugin/1.12.11-0.tar.gz
- sha256sums = 2011e80de9e6c4e5567b726604e4cf274f184d2061bfc8e386c8ee0e70746a50
+ source = ros-lunar-urdf-parser-plugin-1.12.12-0.tar.gz::https://github.com/ros-gbp/urdf-release/archive/release/lunar/urdf_parser_plugin/1.12.12-0.tar.gz
+ sha256sums = de904c290611539796c1ede9d1aad745d34752bb8bb912127b25c7038cb8820f
pkgname = ros-lunar-urdf-parser-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 9412e9b52009..d7c475d52b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - This package contains a C++ base class for URDF parsers."
url='http://ros.org/wiki/urdf'
pkgname='ros-lunar-urdf-parser-plugin'
-pkgver='1.12.11'
+pkgver='1.12.12'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -12,8 +12,7 @@ license=('BSD')
ros_makedepends=(ros-lunar-catkin)
makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- urdfdom-headers)
+ ${ros_makedepends[@]})
ros_depends=()
depends=(${ros_depends[@]}
@@ -22,13 +21,13 @@ depends=(${ros_depends[@]}
# Git version (e.g. for debugging)
# _tag=release/lunar/urdf_parser_plugin/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/robot_model-release.git"#tag=${_tag})
+# source=("${_dir}"::"git+https://github.com/ros-gbp/urdf-release.git"#tag=${_tag})
# sha256sums=('SKIP')
# Tarball version (faster download)
-_dir="robot_model-release-release-lunar-urdf_parser_plugin-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/robot_model-release/archive/release/lunar/urdf_parser_plugin/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('2011e80de9e6c4e5567b726604e4cf274f184d2061bfc8e386c8ee0e70746a50')
+_dir="urdf-release-release-lunar-urdf_parser_plugin-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/urdf-release/archive/release/lunar/urdf_parser_plugin/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('de904c290611539796c1ede9d1aad745d34752bb8bb912127b25c7038cb8820f')
build() {
# Use ROS environment variables
@@ -36,14 +35,14 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
@@ -51,7 +50,8 @@ build() {
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
make
}