summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:50:42 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit65dd41cbb7c36df8612d7d1d30ab6a5eee42959e (patch)
tree87267c5811b608b7533501b3d6fbd51f1434b950
downloadaur-ros-lunar-visualization-tutorials.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD63
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4907c65b71c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:30 UTC 2017
+pkgbase = ros-lunar-visualization-tutorials
+ pkgdesc = ROS - Metapackage referencing tutorials related to rviz and visualization.
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = http://ros.org/wiki/visualization_tutorials
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-rviz-python-tutorial
+ depends = ros-lunar-interactive-marker-tutorials
+ depends = ros-lunar-librviz-tutorial
+ depends = ros-lunar-rviz-plugin-tutorials
+ depends = ros-lunar-visualization-marker-tutorials
+ source = ros-lunar-visualization-tutorials-0.10.1-0.tar.gz::https://github.com/ros-gbp/visualization_tutorials-release/archive/release/lunar/visualization_tutorials/0.10.1-0.tar.gz
+ sha256sums = e6df795104a464e2452c67084025c7aa082016f20a1d3b44a862e0687b781448
+
+pkgname = ros-lunar-visualization-tutorials
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f416b3e4240d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Metapackage referencing tutorials related to rviz and visualization."
+url='http://ros.org/wiki/visualization_tutorials'
+
+pkgname='ros-lunar-visualization-tutorials'
+pkgver='0.10.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-rviz-python-tutorial
+ ros-lunar-interactive-marker-tutorials
+ ros-lunar-librviz-tutorial
+ ros-lunar-rviz-plugin-tutorials
+ ros-lunar-visualization-marker-tutorials)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/visualization_tutorials/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/visualization_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="visualization_tutorials-release-release-lunar-visualization_tutorials-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/visualization_tutorials-release/archive/release/lunar/visualization_tutorials/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e6df795104a464e2452c67084025c7aa082016f20a1d3b44a862e0687b781448')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}