summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242019-12-06 11:45:06 +0100
committerbionade242019-12-06 11:49:51 +0100
commite6ec9edce37160f9d0c52421965856efcdcf9685 (patch)
tree77f1b35ce583d89a3b3a28886b36087decf2428b
parent319d4663179612604e520790b28207f1852dc323 (diff)
downloadaur-e6ec9edce37160f9d0c52421965856efcdcf9685.tar.gz
Updated to python 3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 4 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a27cd631ff0..89a8f21813ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-audio-common
pkgdesc = ROS - Common code for working with audio in ROS.
pkgver = 0.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/audio_common
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 164ccfa6645b..c8e4df5e0130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/audio_common'
pkgname='ros-melodic-audio-common'
pkgver='0.3.3'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-catkin)
@@ -19,13 +19,6 @@ ros_depends=(ros-melodic-sound-play
ros-melodic-audio-common-msgs)
depends=(${ros_depends[@]})
-# Git version (e.g. for debugging)
-# _tag=release/melodic/audio_common/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/audio_common-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
_dir="audio_common-${pkgver}/audio_common"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-drivers/audio_common/archive/${pkgver}.tar.gz")
sha256sums=('9121ce7ea80945a9efb46d89bd33a454877344aa1b4f405f944943a62e1e4bab')
@@ -40,17 +33,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}