summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-02-15 16:48:10 +0100
committerbionade242020-02-15 16:48:10 +0100
commit0816392dee03eee45dd0684fd9fe9fa528053911 (patch)
tree0f3671715fbd85c241a18f9219911825cde8ea6a
parentba2a902d8d87ab6f9db4ab106a75aad571d07961 (diff)
downloadaur-0816392dee03eee45dd0684fd9fe9fa528053911.tar.gz
Fixed arch=() array
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ced3382d30cb..0cba6fd6bfce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = ros-melodic-bondcpp
pkgdesc = ROS - C++ implementation of bond, a mechanism for checking when another process has terminated.
pkgver = 1.8.3
- pkgrel = 2
+ pkgrel = 3
url = https://www.wiki.ros.org/bondcpp
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = BSD
makedepends = cmake
makedepends = ros-build-tools
diff --git a/PKGBUILD b/PKGBUILD
index c73ab82b9abf..38ce32d09194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ url='https://www.wiki.ros.org/bondcpp'
pkgname='ros-melodic-bondcpp'
pkgver='1.8.3'
-arch=('any')
-pkgrel=2
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -63,9 +63,6 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}