summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:49:09 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:49:09 +0200
commit8d6e208911a6a5595669562488027efd40d229fd (patch)
treecbbe676574fb3f83b8902f1fb9304dc40421b59a
parente0ad2ada74a95bd568ae7256fb45aae501c61025 (diff)
downloadaur-8d6e208911a6a5595669562488027efd40d229fd.tar.gz
Update!
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD111
2 files changed, 68 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbe6058b69d6..009f96f9e7d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = ros-melodic-bondcpp
pkgdesc = ROS - C++ implementation of bond, a mechanism for checking when another process has terminated.
pkgver = 1.8.2
- pkgrel = 2
+ pkgrel = 1
url = http://www.ros.org/wiki/bondcpp
arch = any
license = BSD
makedepends = cmake
makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-cmake-modules
makedepends = ros-melodic-bond
makedepends = ros-melodic-smclib
makedepends = ros-melodic-roscpp
- makedepends = ros-melodic-catkin
- makedepends = ros-melodic-cmake-modules
- makedepends = util-linux
makedepends = boost
+ makedepends = util-linux
depends = ros-melodic-bond
- depends = ros-melodic-smclib
depends = ros-melodic-roscpp
- depends = util-linux
+ depends = ros-melodic-smclib
depends = boost
- source = ros-melodic-bondcpp::git+https://github.com/ros/bond_core.git#branch=kinetic-devel
+ depends = util-linux
+ source = ros-melodic-bondcpp::git+https://github.com/ros-gbp/bond_core-release.git
sha256sums = SKIP
pkgname = ros-melodic-bondcpp
diff --git a/PKGBUILD b/PKGBUILD
index 95834c0fc430..1406e8779947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - C++ implementation of bond, a mechanism for checking when another process has terminated."
url='http://www.ros.org/wiki/bondcpp'
@@ -7,67 +7,78 @@ pkgname='ros-melodic-bondcpp'
pkgver='1.8.2'
_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-bond
- ros-melodic-smclib
- ros-melodic-roscpp
- ros-melodic-catkin
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- util-linux
- boost)
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-cmake-modules
+ ros-melodic-bond
+ ros-melodic-smclib
+ ros-melodic-roscpp
+)
-ros_depends=(ros-melodic-bond
- ros-melodic-smclib
- ros-melodic-roscpp)
-depends=(${ros_depends[@]}
- util-linux
- boost)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ util-linux
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/bondcpp/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-bond
+ ros-melodic-roscpp
+ ros-melodic-smclib
+)
+
+depends=(
+ ${ros_depends[@]}
+ boost
+ util-linux
+)
-# Tarball version (faster download)
-#_dir="bond_core-release-release-melodic-bondcpp-${pkgver}-${_pkgver_patch}"
-#source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bondcpp/${pkgver}-${_pkgver_patch}.tar.gz")
-#sha256sums=('efddb54b16d5b2a10b7673832c10cc352bb34354666be2d68b2307ecc742d8e9')
-_branch="kinetic-devel"
_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros/bond_core.git"#branch=${_branch})
+source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git")
sha256sums=('SKIP')
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
+
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir}/bondcpp/ \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}