summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:12:03 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:12:03 +0100
commitdb71e23c74f8d5a6a51cb962c70484f05174ef76 (patch)
treefa66ff3916953bbd0bd75700b8364f588053d201
downloadaur-db71e23c74f8d5a6a51cb962c70484f05174ef76.tar.gz
Update
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD69
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d006baf5105
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ros-melodic-bondcpp
+ pkgdesc = ROS - C++ implementation of bond, a mechanism for checking when another process has terminated.
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = http://www.ros.org/wiki/bondcpp
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-bond
+ makedepends = ros-melodic-smclib
+ makedepends = ros-melodic-roscpp
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-cmake-modules
+ makedepends = util-linux
+ makedepends = boost
+ depends = ros-melodic-bond
+ depends = ros-melodic-smclib
+ depends = ros-melodic-roscpp
+ depends = util-linux
+ depends = boost
+ source = ros-melodic-bondcpp-1.8.2-0.tar.gz::https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bondcpp/1.8.2-0.tar.gz
+ sha256sums = efddb54b16d5b2a10b7673832c10cc352bb34354666be2d68b2307ecc742d8e9
+
+pkgname = ros-melodic-bondcpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e06d70444a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - C++ implementation of bond, a mechanism for checking when another process has terminated."
+url='http://www.ros.org/wiki/bondcpp'
+
+pkgname='ros-melodic-bondcpp'
+pkgver='1.8.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-bond
+ ros-melodic-smclib
+ ros-melodic-roscpp
+ ros-melodic-catkin
+ ros-melodic-cmake-modules)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ util-linux
+ boost)
+
+ros_depends=(ros-melodic-bond
+ ros-melodic-smclib
+ ros-melodic-roscpp)
+depends=(${ros_depends[@]}
+ util-linux
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/bondcpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="bond_core-release-release-melodic-bondcpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bondcpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('efddb54b16d5b2a10b7673832c10cc352bb34354666be2d68b2307ecc742d8e9')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}