summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Exner2020-12-04 11:42:13 +0100
committerFelix Exner2020-12-04 12:52:25 +0100
commit261da0c1dbaea82e555dd250c0bc002ae57eac37 (patch)
tree6f4988f48795ddc83f41a7af55c8083a66d4b977
parentdbc9d256eb36ec4ef55d41e16c68f4d5d874c558 (diff)
downloadaur-261da0c1dbaea82e555dd250c0bc002ae57eac37.tar.gz
Added patch for c++14 requirement of pcl
-rw-r--r--.SRCINFO4
-rw-r--r--CMakeLists.patch10
-rw-r--r--PKGBUILD13
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb474d409213..e1252a2210b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-cartographer-ros
pkgdesc = ROS - Cartographer is a system that provides real-time simultaneous localization and mapping (SLAM) in 2D and 3D across multiple platforms and sensor configurations.
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/googlecartographer/cartographer_ros
arch = any
license = Apache 2.0
@@ -57,7 +57,9 @@ pkgbase = ros-melodic-cartographer-ros
depends = gflags
depends = pcl
source = ros-melodic-cartographer-ros-1.0.0.tar.gz::https://github.com/ros-gbp/cartographer_ros-release/archive/release/melodic/cartographer_ros/1.0.0.tar.gz
+ source = CMakeLists.patch
sha256sums = 874e830d4b3e341cf7f53e66499f84e5f46bb9fda97cfe5d523cee6ec2ebd6d0
+ sha256sums = 18bafe6a7b7c0a894ce2055ace65925dedab29aab0183f56ba01cb8937013b86
pkgname = ros-melodic-cartographer-ros
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..2f862f992809
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.old 2020-06-02 22:37:39.983352068 +0200
++++ CMakeLists.txt 2020-06-02 22:37:49.753352117 +0200
+@@ -15,6 +15,7 @@
+ cmake_minimum_required(VERSION 2.8.12) # Ships with Ubuntu 14.04 (Trusty)
+
+ project(cartographer_ros)
++add_compile_options(-std=c++14)
+
+ set(PACKAGE_DEPENDENCIES
+ cartographer_ros_msgs
diff --git a/PKGBUILD b/PKGBUILD
index c85ab922507b..e063dd8eaa9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='ros-melodic-cartographer-ros'
pkgver='1.0.0'
arch=('any')
- pkgrel=1
+ pkgrel=2
license=('Apache 2.0')
ros_makedepends=(ros-melodic-tf2-ros
@@ -65,8 +65,15 @@
# Tarball version (faster download)
_dir="cartographer_ros-release-release-melodic-cartographer_ros"
- source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-gbp/cartographer_ros-release/archive/release/melodic/cartographer_ros/${pkgver}.tar.gz")
- sha256sums=('874e830d4b3e341cf7f53e66499f84e5f46bb9fda97cfe5d523cee6ec2ebd6d0')
+ source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-gbp/cartographer_ros-release/archive/release/melodic/cartographer_ros/${pkgver}.tar.gz"
+ CMakeLists.patch)
+sha256sums=('874e830d4b3e341cf7f53e66499f84e5f46bb9fda97cfe5d523cee6ec2ebd6d0'
+ '18bafe6a7b7c0a894ce2055ace65925dedab29aab0183f56ba01cb8937013b86')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -uN CMakeLists.txt ../CMakeLists.patch || return 1
+}
build() {
# Use ROS environment variables