summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormajor2020-01-08 13:50:40 +0000
committermajor2020-01-08 13:50:40 +0000
commita03c8c11a29d5c1c7bc186170ea5da286ce0ef2c (patch)
tree447098b56b351d3b6d626a0ac8640b23c93bcca0
downloadaur-a03c8c11a29d5c1c7bc186170ea5da286ce0ef2c.tar.gz
initial commit with adjusted kinetic package (changes python2 to python3, kinetic to melodic
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD64
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..281351a51ee1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ros-melodic-costmap-converter
+ pkgdesc = ROS : converts costmaps
+ pkgver = 0.0.12
+ pkgrel = 1
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = pkg-config
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-costmap-2d
+ depends = ros-melodic-cv-bridge
+ depends = ros-melodic-dynamic-reconfigure
+ depends = ros-melodic-pluginlib
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-message-generation
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-std-msgs
+ depends = python-rospkg
+ options = !makeflags
+ source = ros-melodic-costmap-converter::git+https://github.com/rst-tu-dortmund/costmap_converter.git#tag=
+ sha256sums = SKIP
+
+pkgname = ros-melodic-costmap-converter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ac88964d679
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS : converts costmaps"
+
+pkgname='ros-melodic-costmap-converter'
+pkgver='0.0.12'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools' 'pkg-config' ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-roscpp
+ros-melodic-costmap-2d
+ros-melodic-cv-bridge
+ros-melodic-dynamic-reconfigure
+ros-melodic-pluginlib
+ros-melodic-geometry-msgs
+ros-melodic-nav-msgs
+ros-melodic-message-generation
+ros-melodic-message-runtime
+ros-melodic-roscpp
+ros-melodic-std-msgs)
+depends=(${ros_depends[@]}
+ python-rospkg)
+
+# Git version (e.g. for debugging)
+_dir=${pkgname}
+_tag=${pkgver}
+source=("${_dir}"::"git+https://github.com/rst-tu-dortmund/costmap_converter.git#tag=${__tag}")
+sha256sums=('SKIP')
+options=('!makeflags')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${pkgname} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=-python3.8 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}