summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-09-28 23:16:40 -0400
committeracxz2019-09-28 23:16:40 -0400
commitc54cbfab0c8a091daaa86ec524f41d4276b42d28 (patch)
treeec0eadd6b54e8ea98c1b955d7a0f3385bb17c844
parent58f1e756c6fa86adc980063e8af83198bc796fe4 (diff)
downloadaur-c54cbfab0c8a091daaa86ec524f41d4276b42d28.tar.gz
update to python 3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d19bcc1519c4..23c0c3ac1595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-eigen-stl-containers
pkgdesc = ROS - This package provides a set of typedefs that allow using Eigen datatypes in STL containers.
pkgver = 0.1.8
- pkgrel = 2
+ pkgrel = 3
url = http://eigen.tuxfamily.org/dox/TopicUnalignedArrayAssert.html
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 38a88c02d18e..9c7bc1ac13a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,8 @@ url='http://eigen.tuxfamily.org/dox/TopicUnalignedArrayAssert.html'
pkgname='ros-melodic-eigen-stl-containers'
pkgver='0.1.8'
-_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-melodic-catkin
@@ -20,13 +19,6 @@ ros_depends=()
depends=(${ros_depends[@]}
eigen3)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/eigen_stl_containers/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/eigen_stl_containers-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
_dir="eigen_stl_containers-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/eigen_stl_containers/archive/${pkgver}.tar.gz")
sha256sums=('cf1bcd3253aff0eb032f6d74b9b3c322c99f75ee66bd7034daee8bb2d2a422fc')
@@ -41,17 +33,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}