summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:36:46 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:36:46 +0100
commitc05ead78e439a1bcf3628b1293125b88f1ef8e12 (patch)
tree0512fb0e5e0f1d849aa6b60e0de9e370a63c874d
downloadaur-c05ead78e439a1bcf3628b1293125b88f1ef8e12.tar.gz
Update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD61
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a3049313684
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ros-melodic-gazebo-dev
+ pkgdesc = ROS - Provides a cmake config for the default version of Gazebo for the ROS distribution.
+ pkgver = 2.8.2
+ pkgrel = 1
+ url = http://gazebosim.org/tutorials?cat=connect_ros
+ arch = any
+ license = Apache 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = gazebo9
+ depends = libgazebo9-dev
+ source = ros-melodic-gazebo-dev-2.8.2-0.tar.gz::https://github.com/ros-gbp/gazebo_ros_pkgs-release/archive/release/melodic/gazebo_dev/2.8.2-0.tar.gz
+ sha256sums = 00ea3f63aa55a2417ec2c25241dcd4e78d027a3c967e6032194ed6fbb644cd61
+
+pkgname = ros-melodic-gazebo-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b388f2ab563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Provides a cmake config for the default version of Gazebo for the ROS distribution."
+url='http://gazebosim.org/tutorials?cat=connect_ros'
+
+pkgname='ros-melodic-gazebo-dev'
+pkgver='2.8.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache 2.0')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ gazebo9
+ libgazebo9-dev)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/gazebo_dev/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/gazebo_ros_pkgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="gazebo_ros_pkgs-release-release-melodic-gazebo_dev-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/gazebo_ros_pkgs-release/archive/release/melodic/gazebo_dev/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('00ea3f63aa55a2417ec2c25241dcd4e78d027a3c967e6032194ed6fbb644cd61')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}