summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:52:30 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:52:30 +0200
commitdc357452f21ab71aa54e71433773a416143f106b (patch)
tree012d2130480333b0eeacb4db8491c7f7400a62ae
parent274ee78a582b9e9ce2d28daacdd740c27b4f4b7f (diff)
downloadaur-dc357452f21ab71aa54e71433773a416143f106b.tar.gz
Update!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD101
2 files changed, 60 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afca01396226..ec7e17ad74e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,8 @@ pkgbase = ros-melodic-geometry-msgs
makedepends = ros-melodic-std-msgs
depends = ros-melodic-message-runtime
depends = ros-melodic-std-msgs
- source = ros-melodic-geometry-msgs-1.12.6-0.tar.gz::https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/geometry_msgs/1.12.6-0.tar.gz
- sha256sums = 797d3f77f9265ae2d832e34df4efae1c8f0ada553a7a395ed7969302e405489a
+ source = ros-melodic-geometry-msgs::git+https://github.com/ros-gbp/common_msgs-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-geometry-msgs
diff --git a/PKGBUILD b/PKGBUILD
index 87d29f721d76..da7b6679ae52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - geometry_msgs provides messages for common geometric primitives such as points, vectors, and poses."
url='http://wiki.ros.org/geometry_msgs'
@@ -10,53 +10,68 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-message-generation
- ros-melodic-catkin
- ros-melodic-std-msgs)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs
+)
-ros_depends=(ros-melodic-message-runtime
- ros-melodic-std-msgs)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/geometry_msgs/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-_dir="common_msgs-release-release-melodic-geometry_msgs-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/geometry_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('797d3f77f9265ae2d832e34df4efae1c8f0ada553a7a395ed7969302e405489a')
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}