summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:43:56 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:43:56 +0100
commit1a6a651d5a72cc3f91fbc68abf1e5c107f11dac9 (patch)
treedfcc90a4c44b510e621cae8921abfd7ac209ee77
downloadaur-1a6a651d5a72cc3f91fbc68abf1e5c107f11dac9.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8e2837c478e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-image-common
+ pkgdesc = ROS - Common code for working with images in ROS.
+ pkgver = 1.11.13
+ pkgrel = 1
+ url = http://www.ros.org/wiki/image_common
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-camera-info-manager
+ depends = ros-melodic-camera-calibration-parsers
+ depends = ros-melodic-polled-camera
+ depends = ros-melodic-image-transport
+ source = ros-melodic-image-common-1.11.13-0.tar.gz::https://github.com/ros-gbp/image_common-release/archive/release/melodic/image_common/1.11.13-0.tar.gz
+ sha256sums = 987bdb08a0bf935d3c657331b79564a3e272f6c4538e5be5d893ab6a13865ede
+
+pkgname = ros-melodic-image-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9da76e47286c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Common code for working with images in ROS."
+url='http://www.ros.org/wiki/image_common'
+
+pkgname='ros-melodic-image-common'
+pkgver='1.11.13'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-camera-info-manager
+ ros-melodic-camera-calibration-parsers
+ ros-melodic-polled-camera
+ ros-melodic-image-transport)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/image_common/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/image_common-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="image_common-release-release-melodic-image_common-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/image_common-release/archive/release/melodic/image_common/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('987bdb08a0bf935d3c657331b79564a3e272f6c4538e5be5d893ab6a13865ede')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}