summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:42:57 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:42:57 +0100
commit31e9006d6af12c92a4d98ba84630e30d4bce594a (patch)
treeedcbb05b73b440706230f09b05c7dd67d3a3ead2
downloadaur-31e9006d6af12c92a4d98ba84630e30d4bce594a.tar.gz
Update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD66
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d80fa2a05107
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-interactive-marker-tutorials
+ pkgdesc = ROS - The interactive_marker_tutorials package.
+ pkgver = 0.10.3
+ pkgrel = 1
+ url = http://ros.org/wiki/interactive_marker_tutorials
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-visualization-msgs
+ makedepends = ros-melodic-roscpp
+ makedepends = ros-melodic-tf
+ makedepends = ros-melodic-interactive-markers
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-visualization-msgs
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-tf
+ depends = ros-melodic-interactive-markers
+ source = ros-melodic-interactive-marker-tutorials-0.10.3-0.tar.gz::https://github.com/ros-gbp/visualization_tutorials-release/archive/release/melodic/interactive_marker_tutorials/0.10.3-0.tar.gz
+ sha256sums = 9871ffc4468273f1bd8f38a84e6dafa224057f8ebd89db86e0ab174ab46c06eb
+
+pkgname = ros-melodic-interactive-marker-tutorials
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fa7ab988533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The interactive_marker_tutorials package."
+url='http://ros.org/wiki/interactive_marker_tutorials'
+
+pkgname='ros-melodic-interactive-marker-tutorials'
+pkgver='0.10.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-visualization-msgs
+ ros-melodic-roscpp
+ ros-melodic-tf
+ ros-melodic-interactive-markers
+ ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-visualization-msgs
+ ros-melodic-roscpp
+ ros-melodic-tf
+ ros-melodic-interactive-markers)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/interactive_marker_tutorials/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/visualization_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="visualization_tutorials-release-release-melodic-interactive_marker_tutorials-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/visualization_tutorials-release/archive/release/melodic/interactive_marker_tutorials/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('9871ffc4468273f1bd8f38a84e6dafa224057f8ebd89db86e0ab174ab46c06eb')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}