summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimon Engelke2018-09-11 13:02:16 +0200
committerTimon Engelke2018-09-11 13:02:16 +0200
commitdf2e7de7223c5309ee026ebf023e7cc07aa47a9b (patch)
tree700af06098e96d4c4acc341a11cd9427a619e86a
downloadaur-df2e7de7223c5309ee026ebf023e7cc07aa47a9b.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD58
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb2e3cc64f13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ros-melodic-ivcon
+ pkgdesc = ROS - Mesh Conversion Utility Used to generate .iv files from .stl files.
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://sourceforge.net/projects/ivcon/
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ source = ros-melodic-ivcon-0.1.7-0.tar.gz::https://github.com/ros-gbp/ivcon-release/archive/release/melodic/ivcon/0.1.7-0.tar.gz
+ sha256sums = cbf6855c3a967f5e124a3ea7c6c954bbb57345030d77b22e2f76a77a17bcd3f3
+
+pkgname = ros-melodic-ivcon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c36a438eb97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Timon Engelke <aur@timonengelke.de>
+pkgdesc="ROS - Mesh Conversion Utility Used to generate .iv files from .stl files."
+url='https://sourceforge.net/projects/ivcon/'
+
+pkgname='ros-melodic-ivcon'
+pkgver='0.1.7'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('GPL')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/ivcon/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ivcon-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ivcon-release-release-melodic-ivcon-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ivcon-release/archive/release/melodic/ivcon/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('cbf6855c3a967f5e124a3ea7c6c954bbb57345030d77b22e2f76a77a17bcd3f3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=-python3.7m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}