summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:27:28 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:27:28 +0200
commit8c2a0c4f2146bdc54475a0bcffea49f7f8e7028f (patch)
tree10120996d3227502bb8859035d83069e99924164
parentfb06778abf3e16dfec0c2f92c129f1bdc14d318d (diff)
downloadaur-8c2a0c4f2146bdc54475a0bcffea49f7f8e7028f.tar.gz
Update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD99
2 files changed, 44 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fabd58f316cd..8a7714de044d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,8 @@ pkgbase = ros-melodic-joint-state-publisher
depends = ros-melodic-sensor-msgs
depends = ros-melodic-python-qt-binding
depends = ros-melodic-rospy
- source = ros-melodic-joint-state-publisher::git+https://github.com/ros-gbp/joint_state_publisher-release.git
- sha256sums = SKIP
+ source = ros-melodic-joint-state-publisher-1.12.13-0.tar.gz::https://github.com/ros-gbp/joint_state_publisher-release/archive/release/melodic/joint_state_publisher/1.12.13-0.tar.gz
+ sha256sums = 47bcd5c3c46ffd2d73ee0910bf584a3a23be56e2e423f3849b8771e55fe6fe8e
pkgname = ros-melodic-joint-state-publisher
diff --git a/PKGBUILD b/PKGBUILD
index df6151ca1da1..75b15f5dfe66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - This package contains a tool for setting and publishing joint state values for a given URDF."
url='http://www.ros.org/wiki/joint_state_publisher'
@@ -10,67 +10,52 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-sensor-msgs
+ ros-melodic-python-qt-binding
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-sensor-msgs
- ros-melodic-python-qt-binding
- ros-melodic-rospy
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/joint_state_publisher/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/joint_state_publisher-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/joint_state_publisher-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="joint_state_publisher-release-release-melodic-joint_state_publisher-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/joint_state_publisher-release/archive/release/melodic/joint_state_publisher/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('47bcd5c3c46ffd2d73ee0910bf584a3a23be56e2e423f3849b8771e55fe6fe8e')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}