summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:42:19 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:42:19 +0100
commite67e031fcb52ddcba764c9ce4210ddc4c7366bf4 (patch)
tree2908d6fea0dae7ce7bfc7e7d49182949c696d2f9
downloadaur-e67e031fcb52ddcba764c9ce4210ddc4c7366bf4.tar.gz
Update
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD71
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5e86e2b499f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ros-melodic-kdl-parser
+ pkgdesc = ROS - The Kinematics and Dynamics Library (KDL) defines a tree structure to represent the kinematic and dynamic parameters of a robot mechanism.
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = http://ros.org/wiki/kdl_parser
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-rosconsole
+ makedepends = ros-melodic-urdf
+ makedepends = ros-melodic-orocos-kdl
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-cmake-modules
+ makedepends = tinyxml2
+ makedepends = tinyxml
+ makedepends = urdfdom-headers
+ depends = ros-melodic-rosconsole
+ depends = ros-melodic-urdf
+ depends = ros-melodic-orocos-kdl
+ depends = tinyxml2
+ depends = tinyxml
+ depends = urdfdom-headers
+ source = ros-melodic-kdl-parser-1.13.0-0.tar.gz::https://github.com/ros-gbp/kdl_parser-release/archive/release/melodic/kdl_parser/1.13.0-0.tar.gz
+ sha256sums = 6a0f0427d02d1297d209ab7165118721aaffb3621678e72daf0c57e966a0012f
+
+pkgname = ros-melodic-kdl-parser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f8411afbb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The Kinematics and Dynamics Library (KDL) defines a tree structure to represent the kinematic and dynamic parameters of a robot mechanism."
+url='http://ros.org/wiki/kdl_parser'
+
+pkgname='ros-melodic-kdl-parser'
+pkgver='1.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-rosconsole
+ ros-melodic-urdf
+ ros-melodic-orocos-kdl
+ ros-melodic-catkin
+ ros-melodic-cmake-modules)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ tinyxml2
+ tinyxml
+ urdfdom-headers)
+
+ros_depends=(ros-melodic-rosconsole
+ ros-melodic-urdf
+ ros-melodic-orocos-kdl)
+depends=(${ros_depends[@]}
+ tinyxml2
+ tinyxml
+ urdfdom-headers)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/kdl_parser/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/kdl_parser-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="kdl_parser-release-release-melodic-kdl_parser-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/kdl_parser-release/archive/release/melodic/kdl_parser/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('6a0f0427d02d1297d209ab7165118721aaffb3621678e72daf0c57e966a0012f')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}