summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:11:53 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:11:53 +0100
commitf8f2a75542bfcaa059db475cb0c884ecd264adb5 (patch)
tree4d174802b3acef4c2f31091877e3ac08408bf7b4
downloadaur-f8f2a75542bfcaa059db475cb0c884ecd264adb5.tar.gz
Update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD66
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..528114d2e950
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-map-msgs
+ pkgdesc = ROS - This package defines messages commonly used in mapping packages.
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = http://ros.org/wiki/map_msgs
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-sensor-msgs
+ makedepends = ros-melodic-nav-msgs
+ makedepends = ros-melodic-std-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-sensor-msgs
+ depends = ros-melodic-std-msgs
+ source = ros-melodic-map-msgs-1.13.0-0.tar.gz::https://github.com/ros-gbp/navigation_msgs-release/archive/release/melodic/map_msgs/1.13.0-0.tar.gz
+ sha256sums = a0b7044c2fd59448eb714ce14d60c5ff2d0073962e011e6549c7dd99fc916ffc
+
+pkgname = ros-melodic-map-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9198e65d26ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package defines messages commonly used in mapping packages."
+url='http://ros.org/wiki/map_msgs'
+
+pkgname='ros-melodic-map-msgs'
+pkgver='1.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-message-generation
+ ros-melodic-sensor-msgs
+ ros-melodic-nav-msgs
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-nav-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/map_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/navigation_msgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="navigation_msgs-release-release-melodic-map_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/navigation_msgs-release/archive/release/melodic/map_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('a0b7044c2fd59448eb714ce14d60c5ff2d0073962e011e6549c7dd99fc916ffc')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}